https://community.jivesoftware.com/docs/DOC-40999

 

The new 1.6 version is only compatible with Jive core versions 4.5.5.2 and higher.

 

A separate plugin for Jive core versions older than 4.5.5.2 can be found here.

No bug fixes will be applied to version 1.5. To benefit from bug fixes that occurred after the  initial release of Jive Connects for Office v1.5, you need to upgrade to  Jive 4.5.6 and install Jive Connects for Office v1.6.