Skip navigation

A while back, it was reported that Javascript files that were overlaid in the web/src/main/overlay directory were not being properly minified as part of the build process.  I'm happy to say that this issue has been addressed in the latest version of the jive-parent-pom for Jive versions 6.0.3.4 and up.  Getting the fixes into your project is easy.

 

The next time you build your project, you should see a message similar to the following:

 

[INFO] ************************************************************************************************************************************************

[INFO] Checking for newer versions of jive-parent-pom...

[INFO] You are currently using version 6.0.3.4-3 of jive-parent-pom.

[INFO] The latest version of jive-parent-pom is 6.0.3.4-4

[WARNING] You are not using the latest version of jive-parent-pom.  It is strongly recommended you update your project POMs to reflect this, as follows:

[WARNING] <parent>

[WARNING]     <groupId>com.jivesoftware.maven</groupId>

[WARNING]     <artifactId>jive-parent-pom</artifactId>

[WARNING]     <version>6.0.3.4-4</version>

[WARNING] </parent>

[INFO] ************************************************************************************************************************************************

 

Just follow the instructions, and modify your root POM's <parent> element to point to the appropriate version. 

 

Before rebuilding your project, however, you'll need to make one more change.  In your /web/pom.xml file, remove the following dependencies, as they are no longer needed:

        <dependency>

            <groupId>com.jivesoftware</groupId>

            <artifactId>yuicompressor</artifactId>

        </dependency>

 

 

        <dependency>

            <groupId>com.jivesoftware</groupId>

            <artifactId>yuicompressor-anttask</artifactId>

        </dependency>

 

 

Once you have made these changes, you can rebuild your project, and note that your overlaid Javascript is once again being properly minified.

 

Please reply if you have any questions about this change.

 

Thanks!

Hey everyone.

 

I wanted to let everyone know that we have added full support for Jive 7.0.2.0 to the Jive Maven Unified Archetype.  We created the new 7.0.2.0-compatible version of the jive-parent-pom in conjunction with the 7.0.2.0 GA release on Monday, so you technically have been able to create 7.0.2.0 projects since that time, but the archetype was missing some 7.0.2.0-specific search settings, which could have led so your local search server not starting up correctly. (See the end of this post for details)

 

To recap, in order to create your new Jive 7.0.2.0 project, just enter the following on your command line:

 

$ mvn -U jive:create-project

 

Be sure to specify "7.0.2.0" when prompted for a Jive version.

 

If you already have a Jive project, and want to upgrade it, you can easily start the process by entering the following command at the root of your project, entering "7.0.2.0" when prompted:

 

$ mvn -U jive:upgrade

 

If all this jive:whatever-whatsthisnow craziness is new to you, be sure to check out Announcing Jive Maven Archetype Changes and Moar Archetype Changes! Now Simpler Than Evar!

 

Also, if you're upgrading, and want to incorporate any changes in the archetype into your project, check out and follow Maven Unified Archetype Release Notes.

 

 

Ok, so if you got super excited, and created a new 7.0.2.0 project before this blog post was published, you'll need to make a few changes.

 

If you run the start-search script in the run-services directory, you'll see the following error message:

 

/---------------------------------------------------------------------------------

The follwoing properties are missing and need in-order to start the service.

CONTENT_SEARCH_FILTER_CACHE_ENABLED=true

CONFIG_DIRECTORY=./etc

CONTENT_SEARCH_FILTER_CACHE_SIZE=1000

CONTENT_SEARCH_FILTER_CACHE_TIME_MILLIS=600000

 

 

Add the properties to /path/to/my/project/run-services/main-args.properties and restart the system.

\---------------------------------------------------------------------------------

 

But HOLD ON, because if you add those properties exactly as displayed, your search service won't start up properly, and will just hang.  You'll need to modify the CONFIG_DIRECTORY property to be ./var/data/directory.  Add the following lines to the end of your main-args.properties file:

 

CONTENT_SEARCH_FILTER_CACHE_ENABLED=true
CONFIG_DIRECTORY=./var/data/directory
CONTENT_SEARCH_FILTER_CACHE_SIZE=1000
CONTENT_SEARCH_FILTER_CACHE_TIME_MILLIS=600000

 

 

As always, we welcome your feedback.  Thanks!