The Twitter Plugin has been updated for all versions of Jive 5, 6, and 7. This update is to fix a bug introduced by changes in the Twitter API that made it impossible to connect and configure the plugin. If you are having issues with the Twitter Plugin, please use the latest jars attached to the plugin download page to get the newest version.