Summary

 

Jive currently supports Internet Explorer 9 & 10 within all Jive platforms, including Jive Custom and Jive Cloud.

While both Internet Explorer 9 and 10 will still be able to access Jive after the 2017.1 Cloud upgrade, any issues identified within these browsers will not be fixed or resolved unless it also occurs on Internet Explorer 11 as well. This includes any issues that render the interface non-functional for any users on those browsers. 2017.1's GA date is targeted for Q3 of this year, though customers will be upgraded throughout the latter half of 2017. Further communication on 2017.1 dates will be forthcoming within the next month.

At this time, this policy does not affect Jive Custom users.

Why EOL IE9/10?

 

Both Internet Explorer 9 & 10 were released over 4 years ago and is not able to take advantage of many functionalities and features in a modern web application. For Jive, this limitation is particularly highlighted when using modern JavaScript.

 

Supporting Internet Explorer 9 & 10 over the past few years required our developers to create complex workarounds or making conscious decisions *not* to utilize features that modern browsers support. This prevented us from truly optimizing Jive to create the best experience possible for our users.

 

Finally, Internet Explorer 9 & 10 usage exposes Jive and our users to security risks. Microsoft removed support for Internet Explorer 9 & 10 in January 2016 and has acknowledged that they do not plan on addressing any security issues identified within those browsers.

 

Recommendations & Next Steps

 

Jive Cloud will not lock Internet Explorer 9 or 10 users out of the system, but the 2017 release was not tested nor optimized for those browsers. Moving forward, many critical parts of the application may be non-functional if users are on these versions of IE.

 

It is recommended that users plan on upgrading to Internet Explorer 11.