Troubleshooting Office documents showing as "Read Only" in Jive for Office when opened from Internet Explorer

Version 3



    Some users may be unable to edit or publish Office documents opened from Jive when using Jive for Office due to the document being "Read Only".


    This has been seen when a user opens an Office Document from Internet Explorer.


    The problem is due to a variety of possible security settings in place on the user's computer, which all result in the document being in a "Read Only" state, which prevents users from saving and publishing changes using Jive for Office. It is important to note that this issue is not related to any settings within Jive for Jive for Office, but is related to security settings in Internet Explorer or Microsoft Office


    Identifying the Problem


    • When you open an office document in Microsoft Office, with Jive for Office installed, the user will see that the document's status is "READ ONLY" in Jive for Office
    • The user may also see a message bar in the top of the document reading the following message:

    Read Only View

    This document has been opened in read-only mode. Changes cannot be made to the original document. To save changes, create a new copy of the document.






    This issue may affect all versions of Jive. The issue is due to a misconfiguration of Internet Explorer and Office related security settings. This issue is not related to any specific versions of Jive or Jive for Office



    An office document must be editable by the user who has the document opened for it to function correctly with Jive for Office. If the file is in a "read-only" state while it is opened in Microsoft Office then the user will see the symptoms identified above. This "read-only" state is not something that Jive determines, and instead it is determined by a variety of security settings in Internet Explorer or Office.




    The issue is seen when a user opens an Office document that is in "Read-Only" mode, or is located in a directory that is "Read-Only".  There are two types of workarounds:


    Workaround 1 - Save the file to your desktop or My Documents first

    One way this issue can be avoided is that when a user goes to Jive and downloads a document, the user clicks "Save" instead of "Open" and saves the file in a location like their Desktop or My Documents.



    It has been seen that if a user clicks "Open", the file will open in a "Temporary Internet Files" directory, which they may not have permissions to edit due to various security policies put in place.


    Workaround 2 - Change your security settings in Internet Explorer or Microsoft Office


    If Workaround 1 does not work, another option is to try and change their security settings in Internet Explorer. There are several settings that can be changed. The exact cause of the problem varies from case to case, so it is best to work your way down the list until the issue is resolved.


    1. You can turn off Protected View (the read only for downloaded files) in Office 2010 like this: How to Turn Off Protected View in Office 2010 - iSchool - Answers
    2. You can turn off Protected Mode for IE 10 like this:
    3. Remove the "Read Only" attribute for the "Temporary Internet Files" directory through Internet Explorer: You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, in Wi…
    4. Add your Jive site to the list of Trusted Sites in Tools > Internet Options
    5. Enable "Include local directory path when uploading files to server" option in Internet Explorer security settings:
      1. Tools > Internet Options
      2. Go to Security Tab
      3. Select the appropriate Zone and click "Custom level..."
      4. Scroll down to Miscellaneous
      5. Change "Include local directory path when uploading files to server" to Enabled