Workaround for Impact Metrics showing empty results on all content in Jive 7.0.1

Version 2


    Impact Metrics shows the message 'An error prevented your reports from being displayed at this time.' or all 0's or empty stats on content for hosted 7.0.1.x instances.


    Issue Details

    • Bug ID: JIVE-44271
    • Bug Summary: Cloud Analytics is inadvertently enabled by default for Jive Custom 7.0.1.x / non-cloud sites
    • Affected Versions:,
    • Fix Versions: 7.0.2


    Identifying the Problem


    This document has been verified for version: Jive,


    When a user views a document or question, they see 'An error prevented your reports from being displayed at this time.' under Impact Metrics or the Impact Metrics will report all 0s





    The following error will show up repeatedly in sbs.log:

    2014-05-14 08:57:23,933 [pool-13-thread-1] [4T4Frlx1oe8F20KNbwtY0qJ6INp9uFT6:ANONYMOUS:REGULAR] ERROR - Currently unable to deliver events to endpoint connect timed out


    In 7.0.1.x (not 7.0.0 or 7.0.2), cloud analytics defaults to on for all instances.  Jive core uses the tenancy service to locate the cloud analytics url, but tenancy defaults to off in 7.0.1.x.  As a result, Impact Metrics can't communicate with the cloud analytics api service and displays an error message.


    Only Jive Cloud instances should have cloud analytics on by default, so cloud analytics should be disabled for Jive Custom 7.0.1.x hosted/on-prem instances.



    Disable cloud analytics:

    1. Go to Admin Console: System > Settings > Analytics > Cloud
    2. Set 'Cloud Analytics Settings' to 'Disabled'
    3. Save



    4. Restart the web application nodes


    The cloud analytics setting will take effect immediately in the UI. To clear up the logging error, you will need to restart the application. Impact Metrics will use the local analytics database, and should show counts instead of an error message or blank results.