Version 2

    When accessing Jive from a Java 7 client, an SSL handshake error occurs.  I ran into this when trying to download an applet using the Java 7 browser plugin.

     

    As of Java 7, SNI warnings are considered more serious and result in errors during the SSL handshake.  There are two ways to fix this.  The first solution is to disable SNI on the client.  To do this, add the following option to the Java command that launches the client:

     

    -Djsse.enableSNIExtension=false
    
    
    

     

    If the client is the Java browser plugin, you'll have to open the Java Control Panel (via the jcontrol command).  In the Linux version (sorry - don't have Windows, but it should be similar), go to the Java tab and click View.  Add the above option to Runtime Parameters.

     

    In my case, I don't want to have all my clients have to go in and configure their Java plugins.  To fix it on the server side required having Jive properly identify itself to the client during the handshake.  To do this is pretty easy.  Edit /usr/local/jive/etc/httpd/conf/httpd.conf and add the following line (should be able to go anywhere in the file)


    ServerName <your-host>:<your-port>


    Save the file and restart the HTTPD server and you should be good to go.