Version 2

    Summary

    During a site migration that involves the URL if your community changing you may find that once the migration is complete that images embedded in content like Documents and Discussions no longer work.

     

    If you have properly updated the JiveURL system property and restarted your site and you are still seeing that image links in content are referencing your previous URL then you may need to clear an additional set of caches to restore the images.

     

    Please note, this only works if the images were uploaded directly in the content through the RTE. This workaround does not address issues with widgets - If you have manually created HTML widgets that reference the old URL then you will need to manually update these widgets.

     

    Workaround

     

    Steps for clearing the Rendered Content Cache

     

    1. Go to Admin Console: Spaces > Settings > Filters and Macros
    2. Click the Save button on the page

     

    Just the act of saving that page causes the rendered version of those documents to rerender using the new Jive URL.

     

     

    Cause

    The jiveRenderedContent table contains an additional cache for content published through the RTE. It's not uncommon during migrations and other various tasks to see this table become out of sync with the version sitting in the editor. As a result, it's common practice to clear this cache by using the "Save Settings" button under Admin Console: Spaces > Settings > Filters and Macros.