Version 1

    Summary

    Issue Encountered: Some Space URLs have keywords missing from them despite the "Keywords in Content URLs" being enabled

    Environment

    All instances.

    Steps to Reproduce

    1. Go to Admin Console > System > Setting > New Features.
    2. Make sure the option 'Keywords in Content URLs' is enabled.
    3. Create a Space.
    4. Go to Manage > Permissions to access the admin console.
    5. Add various user groups with various permissions.

    Expected Result

    • While loading the Space, it's URL must contain keywords from the Space Name.

    Actual Result

    • Keywords are missing from the Space's URL.

    Cause

    Per documentation https://community.jivesoftware.com/community/customers/blog/2016/07/11/seo-20162-deep-dive:

    • Content that anonymous users can see will have keywords in URLs
    • No other content will contain keywords in the URLs until it is published to a public location.

    Content that will not contain keywords in the URL includes:

    • Spaces or subspaces with limited access (taken the one point required for this scenario).

    Technically, this means that the User Group, 'Everyone' (i.e. guest) would need access to the specific space having this issue.

    Workaround

    • A permission override for the 'Everyone' group to 'View/Discuss(lower level permission)' can be added to that space and it will not change the access level of the space.
      1. Open the Space.
      2. Go to Manage > Permissions. This will take you to the admin console.
      3. Add user group "Everyone" with desired permissions.
    • By adding an override for the 'Everyone' permissions group, it will allow everyone who is logged into the instance to have the designated access to that specific space(sample image).
    Test Image

    Notes

    The default permission level options (or a custom permission scheme) that could be added can be found here.

    • Admin Console > Permissions > Space Permission Levels