Installing Jive SBS 4.5.5.1 Development Environment on Ubuntu 10.10 (Maverick Meerkat)

Version 4

    For those interested.

    Please note this is NOT A SUPPORTED PRODUCTION environment by Jive, but rather used for Development purposes only (where appropriate).

     

    Before you start,

    • Make sure that you have the following libraries installed:  libssl, libcrypto, and libtermcap
      sudo apt-get install libssl0.9.8
      sudo ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.6
      sudo ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.6
      sudo ln -s /usr/lib/libtermcap.so /usr/lib/libtermcap.so.2
    • Once installed, make the following symlinks for the upcoming Postgres installation:
    • Create a /bin symlink for the basename command, needed for App Configuration scripts
      sudo ln -s /usr/bin/basename /bin/basename

     

    Installing SBS,

    1. Download you RHEL5 (32/64bit) RPM from Jive (in this example I used version 4.5.5.1)
    2. Convert the RPM to DEB using alien (if you do not have installed, sudo apt-get install alien should do it)
      1. sudo alien -c -k /tmp/jive_sbs_employee-4.5.5.1.RHEL-5.i586.rpm
      2. Once completed, alien will generate an equivalent .deb file in the same directory
      3. sudo dpkg i /tmp/jive_sbs_employee-4.5.5.1.RHEL-5.i586.rpm

     

    Random Cleanup,

    If your installation went like mine, postgres wasn't running correctly (possibly due to the symlinks not being created above); however, if you need to manually setup Postgres for you local installation, you can do the following:

    1. If the following directory (/usr/local/jive/var/data/postgres-8.3) does not exist, then
      1. /usr/local/jive/postgres/bin/initdb -D /usr/local/jive/var/data/postgres-8.3
      2. then
      3. /usr/local/jive/bin/psql -A postgres
        CREATE ROLE sbs;
        ALTER ROLE sbs LOGIN;
        CREATE DATABASE sbs OWNER sbs;
        grant create, connect on database sbs to sbs with grant option;
        \q

     

    After my first restart (and the Jive DB had been loaded), I ran into a problem with my Max Shared Memory setting in my kernel being too low for Postgres to start (see var/logs/postgres.log).

    FATAL:  could not create shared memory segment: Invalid argument
    DETAIL:  Failed system call was shmget(key=5432001, size=38207488, 03600).
    HINT:  This error usually means that PostgreSQL's request for a shared memory segment exceeded your kernel's SHMMAX parameter.  You can either reduce the request size or reconfigure the kernel with larger SHMMAX.  To reduce the request size (currently 38207488 bytes), reduce PostgreSQL's shared_buffers parameter (currently 4096) and/or its max_connections parameter (currently 103).
            If the request size is already small, it's possible that it is less than your kernel's SHMMIN parameter, in which case raising the request size or reconfiguring SHMMIN is called for.
            The PostgreSQL documentation contains more information about shared memory configuration.

     

    I ran the following statement to fix it at runtime:

    /sbin/sysctl -w kernel.shmmax=67108864

    and the following change to persist it perminently.

    echo "kernel.shmmax = 67108864" >> /etc/sysctl.conf