Extended APIs Versions Compatibility Matrix

    1. Compatibility to Jive Core by plugin version

     

     

    Jive Version

     

    Extended APIs  v2.0.x

     

    Extended APIs  v2.1

     

    Extended APIs v2.5

    Extended APIs v2.6+

    Extended APIs 3.1

    Extended APIs 3.2 +

    Extended APIs 3.3+

    Extended APIs v3.4

    8.0.0NoNoNoNoNoNoNoYes
    7.0.3.0NoNoNoNoNoNoNoYes
    7.0.2.xNoNoNoNoNoNoYesNo
    7.0.1NoNoNoNoNoYesNoNo
    7.0.0 - 7.0.0.1NoNoNoNoYesNoNoNo
    6.0.3.xNoYesYesYesNoNoNoNo
    6.0.2.xNoYesYesYesNoNoNoNo
    6.0.1.xYesYesYesYesNoNoNoNo
    6.0.0.xYesNoNoNoNoNoNoNo
    5.0.1 +YesYesNoNoNoNoNoNo
    4.5.6.2 +YesNoNoNoNoNoNoNo

     

     

     

     

     

    2. Module compatibility by Core versions and Plugin version

     

    Module NameSupported Core Versions

    Extended APIs v1.1

    EOL - Not Supported

    Extended APIs v1.2

    ( Limited Availability )

    EOL - Not Supported

    Extended APIs v1.3

    EOL - Not Supported

     

    Extended APIs v2.0.x

     

    Extended APIs v2.1

     

    Extended APIs v2.5

     

    Extended APIs v2.6+

     

    Extended APIs v3+

    Jive Anywhere 3.0.x
    • 6.0.1+
    • 7.0.0+
    • 8.0.0+
    NoNoNoNoYesYesYesYes
    Jive Anywhere 2.1
    • 5.0.1+
    • 6.0.1+
    • 7.0.0+
    NoNoNoNoYesYesYesYes
    Jive Anywhere
    • 5.0.1 +
    • 6.0.0.x  + (from EAPIs v1.3)
    • 6.0.1 + (from EPAIs v2.0.x)
    YesYesYesYesYesYesYesNo
    Jive for OCS/Lync v2.0
    • 4.5.6.2 +
    • 5.0.1 +
    • 6.0.0 +
    NoNoYesYesYesNoYesNo
    Jive for OCS/Lync v2.5
    • 6.0.1+
    NoNoNoNoNoYesYesYes
    Jive for SharePoint v1.0
    • 5.0.4 +
    • 6.0.0 +
    NoNoNoYesNoNoNoNo
    Jive for SharePoint v2.0
    • 5.0.4 +
    • 6.0.1 +
    NoNoNoNoYesNoYesNo
    Jive for SharePoint v2.5
    • 6.0.1+
    NoNoNoNoNoYesYesNo
    Jive for SharePoint v3.0
    • 6.0.1+
    • 7.0.0+
    NoNoNoNoNoNoYesYes
    Jive for Office/Outlook v2.0
    • 4.5.6.2 +
    • 5.0.1 +
    • 6.0.0 +
    NoNoNoYesYesNoNoNo
    Jive for Office/Outlook v2.1
    • 5.0.1 +
    • 6.0.1+
    NoNoNoYesYesNoYesNo
    Jive for Office/Outlook v2.5
    • 6.0.1+
    NoNoNoNoYesYesYesNo
    Jive for Office/Outlook v3.0 and v3.1
    • 7.0.0+
    NoNoNoNoNoNoNoYes