2 Replies Latest reply: Jun 27, 2012 1:48 PM by esteban.algueiro RSS

    Jive configuration error - Activity Engine

    Marco Altieri

      I'm trying to install the Jive 5.0.0.1 using Maven. I have already installed the newer version 5.0.1 and it works, but now I have to use the older version.

      Following the same steps I have used for 5.0.1 I'm not able to complete the setup procedure because it complains about the activity engine: "One or more Activity Engine endpoints is not reachable".

      In the log file, that you can find attached, there is the following stack-trace:

      [INFO] [talledLocalContainer] 2011-10-08 12:12:37,489 [http-8080-1] [DDD0247CCB1A8B23E0FC057311868E25:ANONYMOUS] WARN com.jivesoftware.eae.service.client.impl.ServiceClientFactory - Temporarily banning endpoint localhost.localdomain/127.0.0.1:7020 after connect failure

      [INFO] [talledLocalContainer] 2011-10-08 12:12:37,489 [http-8080-1] [DDD0247CCB1A8B23E0FC057311868E25:ANONYMOUS] INFO com.jivesoftware.eae.service.client.impl.ServiceClientFactory - Exception creating connection in ServiceClientFactory

      [INFO] [talledLocalContainer] com.jivesoftware.eae.service.client.ServiceClientException: Failed to connect to localhost.localdomain/127.0.0.1:7020

      [INFO] [talledLocalContainer]   at com.jivesoftware.eae.service.client.impl.ServiceClientFactory.createServiceClient(ServiceClientFactory.java:220)

      [INFO] [talledLocalContainer]   at com.jivesoftware.eae.service.client.impl.ServiceClientFactory.makeObject(ServiceClientFactory.java:169)

      [INFO] [talledLocalContainer]   at com.jivesoftware.community.eae.connection.EAEConfigManager.canConnectToEaeInstance(EAEConfigManager.java:239)

      [INFO] [talledLocalContainer]   at com.jivesoftware.community.eae.connection.EAEConfigManager.isValidConnectPropValue(EAEConfigManager.java:138)

      [INFO] [talledLocalContainer]   at com.jivesoftware.community.action.admin.AdminDatabaseUtilAction.testActivityEngineConnection(AdminDatabaseUtilAction.java:47)

      [INFO] [talledLocalContainer]   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      [INFO] [talledLocalContainer]   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

      [INFO] [talledLocalContainer]   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      [INFO] [talledLocalContainer]   at java.lang.reflect.Method.invoke(Method.java:597)

      [INFO] [talledLocalContainer]   at org.directwebremoting.impl.ExecuteAjaxFilter.doFilter(ExecuteAjaxFilter.java:34)

      [INFO] [talledLocalContainer]   at org.directwebremoting.impl.DefaultRemoter$1.doFilter(DefaultRemoter.java:428)

      [INFO] [talledLocalContainer]   at org.directwebremoting.impl.DefaultRemoter.execute(DefaultRemoter.java:431)

      [INFO] [talledLocalContainer]   at org.directwebremoting.impl.DefaultRemoter.execute(DefaultRemoter.java:283)

      [INFO] [talledLocalContainer]   at org.directwebremoting.servlet.PlainCallHandler.handle(PlainCallHandler.java:52)

      [INFO] [talledLocalContainer]   at org.directwebremoting.servlet.UrlProcessor.handle(UrlProcessor.java:101)

      [INFO] [talledLocalContainer]   at org.directwebremoting.spring.DwrSpringServlet.doPost(DwrSpringServlet.java:158)

      [INFO] [talledLocalContainer]   at com.jivesoftware.community.dwr.JiveDwrSpringServlet.doPost(JiveDwrSpringServlet.java:60)

      [INFO] [talledLocalContainer]   at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)

      [INFO] [talledLocalContainer]   at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

      ...........

      [INFO] [talledLocalContainer] Caused by: java.net.SocketTimeoutException: Read timed out

      [INFO] [talledLocalContainer]   at java.net.SocketInputStream.socketRead0(Native Method)

      [INFO] [talledLocalContainer]   at java.net.SocketInputStream.read(SocketInputStream.java:129)

      [INFO] [talledLocalContainer]   at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)

      [INFO] [talledLocalContainer]   at java.io.BufferedInputStream.read1(BufferedInputStream.java:258)

      [INFO] [talledLocalContainer]   at java.io.BufferedInputStream.read(BufferedInputStream.java:317)

      [INFO] [talledLocalContainer]   at org.apache.thrift.transport.TIOStreamTransport.read(TIOStreamTransport.java:127)

      [INFO] [talledLocalContainer]   ... 120 more

       

       

      At the beginning of the log file there are also other messages:

      [INFO] [talledLocalContainer] Listening for transport dt_socket at address: 8787

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:49 org.apache.tomcat.util.digester.SetPropertiesRule begin

      [WARNING] [talledLocalContainer] WARNING: [SetPropertiesRule]{Server} Setting property 'debug' to '2' did not find a matching property.

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:49 org.apache.tomcat.util.digester.SetPropertiesRule begin

      [WARNING] [talledLocalContainer] WARNING: [SetPropertiesRule]{Server/Service} Setting property 'debug' to '2' did not find a matching property.

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:49 org.apache.tomcat.util.digester.SetPropertiesRule begin

      [WARNING] [talledLocalContainer] WARNING: [SetPropertiesRule]{Server/Service/Engine} Setting property 'debug' to '2' did not find a matching property.

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:49 org.apache.tomcat.util.digester.SetPropertiesRule begin

      [WARNING] [talledLocalContainer] WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'debug' to '2' did not find a matching property.

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:50 org.apache.tomcat.util.digester.SetPropertiesRule begin

      [WARNING] [talledLocalContainer] WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'debug' to '2' did not find a matching property.

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:50 org.apache.catalina.core.AprLifecycleListener init

      [WARNING] [talledLocalContainer] INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/local/jdk1.6.0_27/jre/lib/i386/server:/usr/local/jdk1.6.0_27/jre/lib/i386:/usr/local/jdk1.6.0_27/jre/../lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:50 org.apache.coyote.http11.Http11Protocol init

      [WARNING] [talledLocalContainer] INFO: Initializing Coyote HTTP/1.1 on http-8080

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:50 org.apache.catalina.startup.Catalina load

      [WARNING] [talledLocalContainer] INFO: Initialization processed in 701 ms

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:50 org.apache.catalina.core.StandardService start

      [WARNING] [talledLocalContainer] INFO: Starting service Catalina

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:50 org.apache.catalina.core.StandardEngine start

      [WARNING] [talledLocalContainer] INFO: Starting Servlet Engine: Apache Tomcat/6.0.20

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:55 org.apache.catalina.loader.WebappClassLoader validateJarFile

      [WARNING] [talledLocalContainer] INFO: validateJarFile(/home/jive/glg/web/target/tomcat6x/webapps/ROOT/WEB-INF/lib/eae-service-1.2.0.2.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class

      [WARNING] [talledLocalContainer] 08-Oct-2011 11:53:55 org.apache.catalina.loader.WebappClassLoader validateJarFile

      [WARNING] [talledLocalContainer] INFO: validateJarFile(/home/jive/glg/web/target/tomcat6x/webapps/ROOT/WEB-INF/lib/servlet-api-2.4.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class

      [INFO] [talledLocalContainer] 11:53:57,629 [main] INFO com.jivesoftware.community.web.JiveApplicationContextLoaderListener  - Initializing Jive SBS via web application context event.

      [INFO] [talledLocalContainer] 11:53:57,641 [main] WARN com.jivesoftware.community.JiveHome  - No explicit configuration of Jive root path. Using system default of: '/usr/local/jive'.

      [INFO] [talledLocalContainer] 11:53:57,642 [main] INFO com.jivesoftware.community.JiveHome  - Community home set from system property to '/home/jive/glg/web/../target/jiveHome'.

      [INFO] [talledLocalContainer] 11:53:57,642 [main] WARN com.jivesoftware.community.JiveHome  - Jive root directory does not exist for log configuration. Reverting to JIVE_HOME/logs.

      [INFO] [talledLocalContainer] 11:53:57,645 [main] INFO com.jivesoftware.community.JiveHome  - devMode enabled jive.resources.scripts.copy.classpath - Classpath scripts will not be copied to jiveHome

       

       

      I thought that it has something to do with this issue but I have verified that the same messages are present also in the 5.0.1 that seems to work (except for some error messages that are written on the log file even when the application is working).

       

      Thanks,

      Marco