5 Replies Latest reply on Jan 31, 2008 12:08 AM by ajohnson1200

    image-picker bug on delete image?

       

      Hi,

       

       

      Noticed this with 1.5 and see it still in 1.8 - if I upload an image to a doc, and then click the red 'x'  to delete it in the image-picker window, it doesn't actually delete/disappear and firebug shows javascript error - inst.getContent is not a function.  Not a huge deal but just wondering if it's on the radar or if it might be something on my end.  Thanks.

       

       

        • Re: image-picker bug on delete image?

          hi James,

           

          I just tried uploading and then deleting an image using the image picker on this Clearspace instance and I was able to. Since you mention Firebug I know you're using Firefox so it's definitely not a difference between the browsers we're using. Can you try it here and see if it works?

           

          Cheers,

           

          AJ

            • Re: image-picker bug on delete image?

              I will need to test this out on more machines, but I am still seeing this in 1.9 in both ff and ie7.  I click the red x in the image picker window, get prompted it will remove all references to the image and to confirm, and when I click OK, nothing happens and see js error in status bar - ie7 reports "object doesn't support this property or method" and firebug reports:

               

              inst.getContent is not a function

              deleteUploadedImage(imageid, "image.jpg")image-picker!inpu... (line 515)

              onclick(click clientX=0, clientY=0)image-picker!inpu... (line 1)

              break on this error // call our custom cleanup on the content coming from the editor

               

              Anything clicking on your side from this error output?  Thanks for any info.

                • Re: image-picker bug on delete image?

                  yeah, thanks for that stack trace. That code lives in /template/global/image-picker.ftl, I can see the call to

                  inst.getContent... 

                  . In both cases it's trying to get access to the GUI editor (Tiny MCE) and then to set the content in Tiny MCE, it seems like it's having a hard time getting a handle on the editor. Are you using the plain text editor or the GUI editor when you're seeing this error?

                   

                  Cheers,

                   

                  AJ

                    • Re: image-picker bug on delete image?

                      Good call on the PTE/RTE distinction - if I am in PTE mode, deleting the image in the imagepicker window does indeed work, RTE mode seems to have the problem.  But now I'm also not sure if deleting through imagepicker window is behaving as intended; if I delete it (in PTE), all the imagepath urls \!http://server/spacename/servlet/JiveServlet/downloadImage/imageid/imagename\! that get created on initial upload when you switch modes or save/publish are still valid - the references to the image aren't really removed as the confirmation prompt warns unless you remain in the PTE mode and delete the image after uploading it without switching modes or saving/publishing (it will indeed delete all the \!imagename\! links in PTE mode).  So not sure if this is completely intended behavior or if it is desired to also delete all jiveservlet/downloadImage wiki image url references and that image from the db as well that get created on mode switch/save/publish.  Thanks AJ.