8 Replies Latest reply on Jul 5, 2012 1:59 PM by sivo_kb

    Customizing "Start a Discussion" page

    JonBuck

      I am working on customizing some aspects of our Jive instance. We are currently on Jive 4.5. I am aware of how to make changes in the themes section of the Admin Console; however, not all templates appear to be there.

       

      jive.png

      Above is the area I want to manipulate.

       

      Thanks

        • Re: Customizing "Start a Discussion" page
          sivo_kb

          You don't mention which page this is from. For our instance, we modified our "Tags" comment on two separate templates:

          Documents: /docs/doc-create.ftl

          Discussions: /forums/postform.ftl

          1 person found this helpful
            • Re: Customizing "Start a Discussion" page
              JonBuck

              Bruce


              Thanks for your help. All of the pages where this Tag section is present, it is mis-represented. I am digging through the code to look for the specific section where to modify the text. I only want to change the word "Community" to "comma". Should be pretty simplistic; however, when I view the source code in my browser and identify the <div> where the content is present, I cannot find the same <div> in any of the templates. Any thoughts?

                • Re: Customizing "Start a Discussion" page
                  Ryan Rutan

                  Make sure you are using a DOM inspector, rather than a simple view source utility.  In many cases, dynamic html / javascript create HTML in the DOM on the fly … and it is not part of the original HTML source received from the server.  In Firefox/Chrome, if you right/click and inspect…that is a good DOM viewer where you should be able to find the necessary elements.  Hope this helps.

                  • Re: Customizing "Start a Discussion" page
                    sivo_kb

                    Jon,

                     

                    If you haven't solved this yet, I'm quite sure I know what's happening.  You probably have a "Phrase substitution" set up (System -> Settings) that changes all instances of Spaces to Communities.  You can solve this through the System -> Settings -> Themes page.

                     

                    First, click on the edit icon for your currently-used theme.  Then on the Edit Theme menu, click the Edit Rules button under Phrase Substitutions. This will reveal all 4 variations of "Spaces" that are being replaced.  I recommend deleting the third variation "\bspaces\b", which will fix your issue (though it will now say "use spaces to separate multiple tags...", not "use commas...".

                     

                    Alternatively, you can try to use the "Add Exception" feature, though we had trouble getting that to work properly.

                     

                    Hope this helps,

                    Bruce