"openssl < 0.9.9 needed" with "openssl-1.0.0-25.el6_3.1.x86_64 already installed" seems to be an issue. Try to use an older SSL (0.9.8) version.
Whichever plugin is already installed related to plugins for which you get the error, try to uninstall that and then try to install the plugin whichever is required (e.g. 0.9.8 for openssl).
Hope this will solve your issue.
Make sure all the dependencies are installed with higher version than what is mentioned in error.
Then try to install jive rpm with "nodeps".
#rpm -ivh --nodeps jive_sbs_employee-220.127.116.11.RHEL-5.x86_64.rpm
It will not throw any error but it is very important that first you check the dependencies with higher version are installed or not. make sure about the dependencies then only run the above command otherwise you will face problem in later part. Hope it will help you.