18 Replies Latest reply on Oct 27, 2012 11:57 AM by it2000

    Problem in using curl with Jive cloud REST API (v3)

      Hello Everyone,

       

      I was trying to access REST API (v3) through curl using following syntax:

      curl -k -u username:password -i '{ fields: "@summary", count: 5 }' https://apps-onprem.jivesoftware.com/api/core/v3/activities (-k for insecure) and then I got:

      curl: (3) [globbing] unmatched brace at pos 3

      curl: (6) Could not resolve host: fields; Host not found

      curl: (6) Could not resolve host: summary,; No data record of requested type

      curl: (6) Could not resolve host: count; Host not found

      curl: (6) Could not resolve host: 5; Host not found

      curl: (3) [globbing] unmatched close brace/bracket at pos 1

      HTTP/1.1 404 Not Found

      Date: Wed, 24 Oct 2012 05:45:04 GMT

      Server: Apache-Coyote/1.1

      Allow: GET,OPTIONS,HEAD

      Content-Type: text/xml

      Content-Length: 0

      Expires: Wed, 24 Oct 2012 05:45:04 GMT

      Vary: Accept-Encoding,User-Agent

      Cache-Control: no-store, no-cache, must-revalidate, private, max-age=0

      X-JSL: D=315674 t=1351057504119112

      Set-Cookie: jive.user.loggedIn=true; Path=/;HttpOnly

      Set-Cookie: jive.server.info="serverName=apps-onprem.jivesoftware.com:serverPort=443:contextPath=:localName=jiveapps-developer-wa01.sgvm2hosted.jiveland.com:localPort=9200:localAddr=127.0.0.1"; Version=1; Path=/;HttpOnly

      Set-Cookie: BIGipServerPool_VMP2_2_C1.123=2198698506.20480.0000; path=/

       

      And to my surprise when I tried same thing with Jive REST v2 API with following syntax:

      curl -k -u username:password https://appsonprem.jivesoftware.com/api/core/v2/activity?limit=10

      It worked & showed me 10 results.

       

      What I am missing here? Why v2 is working and not v3?

      Can anyone please help me out.