5 Replies Latest reply on Sep 2, 2008 1:51 PM by laphroaig15

    Email monitor error

      One of our users got an error when responding to a discussion thread:

       

      An email reply you sent was not processed for the following reason:

      There was an error while creating your reply in the forum. If you need

      assistance or have any questions, please contact the system administrator.

       

      I've dug through the logs and looked at the source. Any clues on where to look for the real problem? Is there an incoming mail spool directory somewhere?

       

      TIA,

      Doug

        • Re: Email monitor error

          hi Doug,

           

          Looks like we don't push any additional information about a rejected message to the logs.  Looks there are a couple reasons why an email message would get rejected:

           

          a) the thread has been archived

           

          b) the thread has been locked

           

          c) the user doesn't have permission to reply to a message in the community / space

           

          d) the user has been banned

           

          Do any of those match up to the case you brought up?

           

          Cheers,

           

          AJ

            • Re: Email monitor error

              Well...

               

              I think they were just testing the email response stuff. What does it man to have a thread "locked"? Is that a manual process? Or does the thread get locked during updates, to avoid corruption?

               

              Thanks,

               

              Doug

                • Re: Email monitor error

                  A system admin, community admin or moderator can 'lock' a thread so that no one can add more content to it. It's a feature designed for situations when maybe you don't want a thread to get out of control because people are calling each other names or something.

                   

                  Cheers,

                   

                  AJ

                    • Re: Email monitor error

                      Well then, I'm a little concerned because none of the possible causes apply to us. It's only happened once, and it was during some testing where several messages were being submitted in rapid succession.

                       

                      I'll keep an eye on this. In case it returns, is it possible to turn on more debug output?

                       

                      Thanks,

                       

                      Doug

                  • Re: Email monitor error

                    Are there any other known issues that cause this error?  I've installed Community 2.5 rc1 in a sandbox and I'm receiving this same email when replying to a post.  I've enabled email debug and trace level logging, but nothing gets logged to describe what caused the error.  I can log in with the same user account and readily reply by web.

                     

                    Edited:  I found a stack trace in the app server logs.  The error seems specific to community 2.5.  I've opened a new thread here.