6 Replies Latest reply on Jun 4, 2007 3:14 PM by rdellimmagine

    Configuring Private Communities

    rdellimmagine

      I have a top-level space configured that anyone can see, but only registered users can post to.  This is straightforward to set up in Clearspace, i.e. the first three boxes in the anyone row on the permissions screen have green checks, and the rest of the boxes  in the registered users row have green checks.

       

      Here's the hard part.  Within that community, I would like to create a sub-space that only users in a certain group can participate in.  So I set up a group, added users to it, went to the permissions screen and selected the grant new permissions tab and gave my new group the permissions I wanted, i.e. all the boxes have green checks.

       

      In this case, though, everyone can see them because the anyone and registered users row inherit from the parent space.  So, I went in and put red x's in the anyone and registered users row.

       

      And here's the bad part.  Now no one can see this subspace because the anyone and registered users row takes precedence over the group that I set up.

       

      I'm wondering if this is a bug.  Shouldn't the group take precedence over the anyone and registered users?

       

      Or if there's a way around this, please let me know.   Thanks!!

        • Re: Configuring Private Communities

          hi rdellimmagine,

           

          Everything you did sounds exactly right to me. I downloaded 1.1.1 (I'm assuming you're using the latest?) and ran through a new install. I set the permissions on the root space  so that the first three checkboxes on the 'Anyone' group were checked and then checked all the boxes for the 'Registered Users' group (see attached screenshot global_permissions.png). Then I created a Space called 'foo', selected the 'private' option during the wizard (which results in red x's for every box for both registered users and anyone group, and then added rights for a group called 'test' (see attached screenshot foo_permissions.png).  Then I went to the homepage of the site and logged in as a user 'aaron' who wasn't part of the 'test' group.  The user 'aaron' was not shown the 'foo' space.  I logged out and logged in as a user 'test', who was part of the 'test' group. The user 'test' was able to see the space 'foo'.

           

          Are you using LDAP for your users or the database? What version of Clearspace are you on? What edition (internal or external)?

           

          Cheers,

           

          AJ

          • Re: Configuring Private Communities

            Hi rdellimmagine,

             

            I cannot reproduce your situation.  Here are the steps i followed to try:

             

            1. Top level space: the first three boxes in the anyone row on the permissions screen have green checks, and the rest of the boxes in the registered users row have green checks *(as you have set up)

             

            2. Created a subspace

             

            3. Created a group, added a user

             

            4. Set up permissions to have all red x's in anyone and registered users for subspace

             

            5. Set up permissions for group to have all green check boxes

             

            6. I then logged in as the user in the group (with permissions) and i was able to see the subspace

             

            7. Logged out, logged in as a user not in the group, and i was not able to see the subspace

             

            8. Logged out, browsed as anonymous user and could not see the subspace

             

            So, for me this worked as expected.

             

             

            So, maybe if you're still having trouble you could tell me:

             

            a. What version of Clearspace are you using?

             

            b. What steps you are doing differently?

             

             

            -Will