2 Replies Latest reply on Jun 26, 2007 7:39 AM by ammulder

    Problem with custom AuthFactory in Clearspace 1.1.1

      I'm trying to use Crowd with Clearspace 1.1.1.

       

      I see different behavior the first time I run Clearspace and every subsequent time.

       

      The first time, my custom AuthFactory is instantiated, and Clearspace seems to be aware of an already logged-in user from Crowd.

       

      After I restart the app server, my custom AuthFactory is not instantiated, and Clearspace ignores any existing Crowd login and attempts to resolve logins against its own database.

       

      Any ideas on how to force it to always instantiate and use the custom AuthFactory?

        • Re: Problem with custom AuthFactory in Clearspace 1.1.1

          hi ammulder,

           

          How did you configure Clearspace to use your custom AuthFactory? A build property? A Jive property? Do you see any error messages in your logs?

           

          You might try turning on the debug logs via the admin console --> system --> log viewer --> debug tab.

           

          Cheers,

           

          AJ

            • Re: Problem with custom AuthFactory in Clearspace 1.1.1

              I configured ClearSpace to use a custom UserManager, GroupManager, and AuthFactory using the screen for that in the setup tool.

               

              If there are other ways to specify those in a config file, I would be happy to try that -- can you give me some pointers?

               

              For what it's worth, I just tried ClearspaceX 1.2 and I have the same behavior.  During the first run when I go through the full setup wizard, the custom AuthFactory is loaded and single sign-on works.  However after restarting the app server and going through the mini-setup-wizard (confirming home dir and license details), the custom AuthFactory is not loaded and single sign-on does not work.