9 Replies Latest reply on Oct 7, 2007 7:55 PM by chrislucas

    Change default ip for clearspace/ vhosts?

      Hi

       

      I have a slight situation here We are running 2 instances on the same box, one Openfire and the other Clearspace.

       

      Openfire is using port 80 and 8080. And Clearspace is using port 8008. Same ip.

       

      We would however like to setup some form of virtual host,

      ie

      clearspace.(domain)

      openfire.(domain)

       

      And when requests for those hostnames are made, they get filtered via the port.

       

      ie

       

      anything on port 8008 , gets rewriting to be clearspace.(domain) etc

      (so that when accessing clearspace, you dont have to specify the port, ...looks messy)

       

      Is this possible?

       

      I did try a number of things with no luck.

      So I added an additional ip to the machine.

      So that both Openfire and Clearspace run on dedicated ip's.

       

      This however proved to be another issue as both Openfire and Clearspace use all interfaces by default.

      So they all running on the same ports on the both ip's

       

      Then I located within the openfire conf xml a way to set it to only one ip.

      And now im struggling to figure it out on Clearspace.

       

      I hope someone can make sense of my nonsense here.

       

      Please shed some light for me.

       

      Many thanks in advance.

       

      -- junior clearspacier --

        • Re: Change default ip for clearspace/ vhosts?

          Hey waCraig,

           

          Sorry I don't have an answer for you, but I'm going to watch this thread like a hawk because I have a somewhat similar issue.

           

          We have IIS and Tomcat running on the same physical machine.  IIS hosts some website (not Clearspace) and Tomcat hosts Clearspace.   Both IIS and Tomcat have been assigned their own IP addresses.  In IIS you can configure this in IIS manager and in Tomcat I believe you do this in server.xml. 

           

          "In theory", this configuration allows you to have both IIS and Tomcat live on the same machine using port 80, because they each are running on their own dedicated IP addresses.

           

          Unfortunately for us, IIS continues to work fine.  But when we try to hit Tomcat (ie. Clearspace), we're constantly getting HTTP 400 (Invalid Hostname) errors.  

           

          I know it's not the same issue that you're seeing, but I'm still interested in your issue.  If anyone has any ideas/suggestions for either of us, that would be great

           

          Cheers,

          Dave

            • Re: Change default ip for clearspace/ vhosts?

              Ye, IIS having easy to add host headers, is wonderful.

              However I love working on Linux and after getting Openfire to run on one IP.

              I am determined to do the same for Clearspace.

               

              Either by vhost or dedicated ip.

               

              One other thing, has anyone attemped to rewrite the URL?

              IE. http://clearspace.domain.net:8080/clearspace/ to http://clearspace.domain.net

               

              Would love some info on that as well.

               

              Thanks.

               

              ciao

                • Re: Change default ip for clearspace/ vhosts?

                  Hi folks,

                   

                  Just to close the loop on my part of the thread for anyone interested.  We wanted to run Clearspace with Tomcat use port 80 on one IP address on the server and have some other website with IIS use port 80 on another IP address on that same server.  We were getting Error 400 (Invalid Hostname) messages when connecting to Clearspace and couldn't figure out why.

                   

                  And this is where it gets <sarcasm>awesome</sarcasm>.  As odd as it may seem, when IIS starts, it binds to all IP addresses on the server, not just the IP addresses that are assigned to web sites that IIS is configured to serve.  More specifically,  the service does not bind every IP Address in the system explicitly, but binds to a generic address 0.0.0.0.  So when you tell it to only listen to a specific IP address it still binds to every IP Address and every NIC in your system. 

                   

                  You can tell that this is happening by entering the following command at the DOS prompt:

                   

                  netstat -an|more

                   

                  Have a look at the output.  You will see that a lot of the services are connected to 0.0.0.0.  Among those services may be SMTP (25), POP3, NNTP, HTTP (80) and HTTPS (443) when they are installed.

                   

                  To make it stop doing this, you have to disable socket pooling.  Depending on the version of IIS you're running, the steps vary to a degree.  But there's more information on this in the MS KB here:

                   

                  http://support.microsoft.com/kb/813368/EN-US/

                   

                  and...

                   

                  http://support.microsoft.com/kb/238131/

                   

                  Now, sorry to interrupt waCraig!  Let's get back to solving your issue!

                   

                  Cheers,

                  Davey