9 Replies Latest reply on Aug 6, 2007 12:50 AM by jonaslar

    Clearspace incompatibilty with WAS 6.1.0.7?

    jonaslar

      I have tried both the war-file installation in WebSphere 6.1.0.7 on Linux and the standalone version of ClearSpace.

       

      To make the WebSphere-installation work I had to add to the war-file clearspace.war\WEB-INF\ibm-web-ext.xmi, specify jsp source lvl like this:

       

        <jspAttributes xmi:id="JSPAttribute_5" name="jdkSourceLevel" value="15"/>

       

      This made me access the admin-pages without the error message:

       

      "Syntax error, parameterized types are only available if source level is 5.0"

       

      And I had to add a parameter to the WebSphere WebContainer "com.ibm.ws.webcontainer.invokefilterscompatibility=true"

       

      But I still have some problems that I have in the WebSphere-installation, but not in the standalone-installation.

       

      1) In the Rich Text Editor the format buttons shows as text and not as buttons.

      2) In the Admin client I cant add author in several views

      3) "User Picker" does not pop up anywhere when the link is clicked

       

      There might be more differences.

       

      Anyone else tried the configuration with ClearSpace on WAS 6.1.0.7 and Linux?

       

      Best Regards

      Jonas

        • Re: Clearspace incompatibilty with WAS 6.1.0.7?
          jonaslar

          By the way, tried both Firefox and IE 6 with same behavior.

           

          Jonas

          • Re: Clearspace incompatibilty with WAS 6.1.0.7?
            jonaslar

            I have installed ClearSpace version 1.3.0.

            Upgraded today to WAS 6.1.0.9 without that fixing the problem.

             

            Jonas

            • Re: Clearspace incompatibilty with WAS 6.1.0.7?
              jonaslar

              Here is the "System Info" from the CS admin pages:

               

              Jive Home:      /opt/jiveHome

              Uptime:      8 minutes 12 seconds

              Clearspace Version:      1.3.0

              JVM Version and Vendor:      1.5.0 IBM Corporation

              Application server:      IBM WebSphere Application Server/6.1

              Operating System:      Linux

              Hardware:      x86

              Country database version:      GeoIP Country Edition 01/2007    (Update Country Database)

              User Manager:      com.jivesoftware.base.profile.UserManagerImpl

              Group Manager:      com.jivesoftware.base.database.DbGroupManager

              Auth Manager:      com.jivesoftware.base.profile.BasicAuthFactory

               

              Datasource Info

              Database Name and Version:      Oracle Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bit Production With the Partitioning, OLAP and Data Mining options

              JDBC Driver and Version:      Oracle JDBC driver 10.2.0.3.0

              Subqueries supported:      Yes

              Transactions supported:      Yes

              Transaction isolation level:      Read Committed

              Connection Pool:      JNDI Connection Pool

              JNDI Connection Name:      jdbc/clearspace

               

              , and some java-information:

               

              # ./java -version

              java version "1.5.0"

              Java(TM) 2 Runtime Environment, Standard Edition (build pxi32devifx-20070608 (SR5+IY99712))

              IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Linux x86-32 j9vmxi3223-20070426 (JIT enabled)

              J9VM - 20070420_12448_lHdSMR

              JIT  - 20070419_1806_r8

              GC   - 200704_19)

              JCL  - 20070608

              #

              • Re: Clearspace incompatibilty with WAS 6.1.0.7?
                jonaslar

                All issues have been fixed in Clearspace 1.4.0, as long as you ensure that name="jdkSourceLevel" value="15" is set before compiling the JSP's, and add a parameter to the WebSphere WebContainer "com.ibm.ws.webcontainer.invokefilterscompatibility=true".

                WAS 6.1.0.7 or newer is a prereq ot use the last parameter.

                 

                Jonas