9 Replies Latest reply on Aug 29, 2007 12:11 PM by dcarter

    Email monitor delays

      We're running 1.3 and have the email monitor (via POP) turned on. However, there is a delay in delivery. Any mail sent to a thread will be delayed until another web post is made to the thread.

       

      Any ideas on this?

       

      Thanks,

       

      Doug

        • Re: Email monitor delays

          Hi,

           

          Do you happen to have the system property of "checkmail.frequency" set to anything?

           

          The path should be: Email sent in, inbox checked every 30 seconds (returns a list of new emails), list is processed and then new messages are added.

           

          -Will

            • Re: Email monitor delays

              Yes, it's set to 30.

               

              Doug

                • Re: Email monitor delays

                  Do your log files contain any information regarding email problems?

                    • Re: Email monitor delays

                      No, but it's full of other exceptions, like jdbc connection errors and "no such user" errors:

                       

                      2007.08.21 16:17:12 schenven

                      com.jivesoftware.base.UserNotFoundException: schenven

                              at com.jivesoftware.base.profile.UserManagerImpl.getUser(UserManagerImpl

                      .java:202)

                              at com.jivesoftware.base.profile.UserManagerImpl.getUser(UserManagerImpl

                      .java:187)

                              at com.jivesoftware.community.impl.DbPresence.getUser(DbPresence.java:59

                      )

                              at com.jivesoftware.community.impl.DbPresenceManager.setOffline(DbPresen

                      ceManager.java:341)

                              at com.jivesoftware.community.web.PresenceListener.sessionDestroyed(Pres

                      enceListener.java:88)

                              at org.apache.catalina.session.StandardSession.expire(StandardSession.ja

                      va:697)

                              at org.apache.catalina.session.StandardSession.isValid(StandardSession.j

                      ava:581)

                              at org.apache.catalina.session.ManagerBase.processExpires(ManagerBase.ja

                      va:679)

                              at org.apache.catalina.session.ManagerBase.backgroundProcess(ManagerBase

                      .java:664)

                              at org.apache.catalina.core.ContainerBase.backgroundProcess(ContainerBas

                      e.java:1285)

                              at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.p

                      rocessChildren(ContainerBase.java:1570)

                              at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.p

                      rocessChildren(ContainerBase.java:1579)

                              at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.p

                      rocessChildren(ContainerBase.java:1579)

                              at org.apache.catalina.core.ContainerBase$ContainerBackgroundProcessor.r

                      un(ContainerBase.java:1559)

                              at java.lang.Thread.run(Thread.java:619)

                       

                      I started a thread on this, but haven't gotten an answer yet.

                       

                      Doug

                • Re: Email monitor delays

                  hi Doug,

                   

                  I stepped through the code the other day after reading your post, convinced that this was an issue with our internal caching but for the life of me I can't see how this could be happening.  So forgive the inane questions, but I'm grasping at this point:

                   

                  a) any idea how many emails are getting sent to and from Clearspace per day?  per hour?

                   

                  b) is there a single person who consistently sends a lot of email and who runs into this problem?

                   

                  c) is it consistent? does the delay happen every time?

                   

                  Cheers,

                   

                  AJ

                    • Re: Email monitor delays

                      Hi AJ,

                       

                      I understand your need for more data. Unfortunately, our main admin is on vacation and I don't have all the details you need. Here is what I would say to your questions:

                       

                      a) Very few, 2-5 per day.

                       

                      b) I think it's only been a problem with one or two people.

                       

                      c) As I understand it, the delay is consistent and repeatable. Any email sent to a thread is not posted, until a manual posting (via the web) is made.

                       

                      I'll have more data when the admin returns.

                       

                      Thanks,

                      Doug

                        • Re: Email monitor delays

                          k, that's cool. I'll ask around internally and find out if anyone has been seeing delays when replying to email.

                           

                          Cheers,

                           

                          AJ

                          • Re: Email monitor delays

                            hi Doug,

                             

                            Asked around about this and ran through a bunch of tests against our own internal instance that we use as our intranet.  One thing to check: how many messages are in that inbox (you can check by logging in using a POP3 compatible email client, make sure to check the option that says something like 'leave email on server')?

                             

                            Cheers,

                             

                            AJ

                              • Re: Email monitor delays

                                I have tested this yet, but in all the times we've seen the problem, there is only one message in the queue. Going back to the original description of the problem. We send an email response, and it will not show up, until someone posts a reply via the web. It's as if the web posting is "unblocking" the queued email.

                                 

                                I'll try to do some more specific testing in the next few days.

                                 

                                Thanks again.