6 Replies Latest reply on Nov 20, 2007 2:26 PM by rchady

    Problem upgrading 1.2.0 -> 1.6.0

    rchady

      So, I followed the Upgrade document for upgrading Clearspace and it does not seem to go quite as smoothly as would be indicated.  Anyhow, I noticed there were some new tables created so I manually created them.  Now it flat out won't start up and the main error I see is:

       

      2007.09.28 04:05:07 XML properties file does not exist: /h

      ome/clearspace/jive_clearspace_standalone_1_6_0/jiveHome/null

       

      Which does not seem to bode well for this starting...

       

      So, is there an actual upgrade process here?  It would seem I either missed some major documentation or it does not exist for upgrading beyond one step.

       

      Thanks!

       

      --Robert

        • Re: Problem upgrading 1.2.0 -> 1.6.0

          Hi Robert,

           

          Barring any customizations you may have in place, upgrading should just involve setting up a new clearspace instance (the new version) and pointing it to your jive home and your database in the setup process.  It should make any database changes in and of itself (as well as any new config files that it needs.)

           

          What problems exactly did you run into in this process?  How precisely did you go about upgrading?  It looks like it's having trouble with your jivehome ... does the path it lists point to your old jivehome?

           

          Cheers,

          Chase

            • Re: Problem upgrading 1.2.0 -> 1.6.0
              rchady

              Well, the approach you mention is basically what I did.  I figured it would be pretty straight forward, but I was wrong.

               

              The steps I took were right out of the ClearspaceUpgradeMigrationGuide document:

               

              (paraphrased)

               

              1) Backup jiveHome

              2) Backup database

              3) Backup server/shared/lib

              4) Install

              5) Move the new jiveHome aside and symlink to the backed up version

              6) move JDBC driver over

              7) Start clearspace

               

              When I started the server back up, it did not come up.  Looking through the logs I saw it erroring out because certain tables did not exist.  After I added the tables it was missing from the db schema file, I tried again.  This time when it loaded up it printed out the error in my first posting.

               

              Yes, the paths to jiveHome are correct.  No, I still do not have this working.

               

              So, at this point I am quite stuck.  Any ideas?

               

              --Robert

                • Re: Problem upgrading 1.2.0 -> 1.6.0

                  I'm not sure if this will help you or not, but when I upgraded from 1.2.0 -> 1.4.0 I had the same problem. I ended up restoring everything back to 1.2.0 and then performing the upgrade by installing each release in order (1.2.0->1.3.0->1.4.0->etc.). Everything worked just fine afterwards.

                   

                  If I recall, upgrading in order did not take that long. It was just simply a matter of replacing the war, restarting the app server, running the admin setup tool, and then repeating until it was on the current version.

                   

                  Now I just upgrade in order no matter what because of the table changes from version to version. It would be nice to have some table scripts for upgrading from previous versions though (you guys work so fast it is hard to keep updated with your release schedule, but good job on the product!).

                  • Re: Problem upgrading 1.2.0 -> 1.6.0

                    hi Robert,

                     

                    Thanks for your patience, sorry it's not working yet.  It sounds like you're using the standalone version of Clearspace.  Is that right?  Can you try not symlinking to the backed up version of jiveHome?  If you do that and then restart your app server, you should be popped back into the setup process, where you'll probably have to enter in the setup information again (lame, I know, but bear with me).  After you get through the setup process (which should automatically create the schema in your database, you shouldn't need to create tables manually unless the user you're using to authenticate against your database doesn't have permission to create tables), you should then get kicked into the upgrade process, where you should be presented with a list of tasks that the system will process for you.

                     

                    Long winded, but give it a try. Ping me via email (aaron@jivesoftware.com) if that doesn't work for you.

                     

                    Cheers,

                     

                    AJ