3 Replies Latest reply on Oct 23, 2007 8:36 AM by scott.hirdes

    Timeout and Keep Alive during the creation of a message post.

      Hi Clearspace Support


      We have a global SSO session timeout of 15 minutes on our Oracle Application Server environment.  With our Clearspace integration, we have it linked into our SSO and therefore, if logged-in users have not interacted with the server for a period of 15 minutes, then they will get logged out.  We have had numerous problems with our members creating a message post for more than 15 minutes because some of our users write lengthy messages and proofread their messages prior to pressing the Post Button.  This can take longer than 15 minutes.


      What is happening is that after pressing the Post button, they are prompted to re-login but they lose their post.   This is causing numerous production issues with our users.


      Since we do not want to increase our expiration timeout, we would at least like to keep the session alive while a user is busy editing a post.  We have speculated that a possible solution could be to enable two system settings for the autosave feature so that it would cause an action with the server and therefore, would allow the session to continue.

      The settings would be:

      draft.autosave.enabled = true

      draft.autosave.interval = 300 


      Is this an appropriate solution?



      Does Clearspace (or Jive Forums) have a better solution?



      We are using ClearspaceX v1.2.

        • Re: Timeout and Keep Alive during the creation of a message post.



          Another possible solution would be to change the session timeout value just for the Clearspace install by changing the value for session timeout in the web.xml file in the clearspace WEB-INF directory of your application server.  This timeout value would then override the global timeout value of the application server just for Clearspace sessions.


          As for the the autosave properties, looking at the code it appears that autosave is enabled by default with an interval of 30 seconds so unless you have explicitly disabled autosave previously, it should already be active.  In my own testing locally, it appears that having autosave enabled with an interval less than the session timeout time does indeed keep the session open because, as you suggested, it causes action with the server.


          Finally, it is my understanding that Harpo has some custom authentication code.  As such, I cannot test these possibilities with your exact implementation and so cannot give a definite answer.  I would advise that you try changing the timeout value in the Clearspace web.xml file first.  If that doesn't work, then I would advise opting for the autosave option by setting the properties you discovered (although again, it appears that these should be enabled by default).