9 Replies Latest reply on Nov 16, 2007 2:19 AM by peterb

    Problems with Images in PDFs

      Hello all, I'm using Clearspace 1.6 and I'm finding very strange results with images inside PDFs from Wiki Documents.

       

      Basically it appears only some images end up in a PDF generated from a wiki document. I've tested small to large images and it seems the smaller ones tend to end up in the PDF generally okay. Mid sized images mostly don't and in general images larger than 900x600 don't appear in the PDFs at all. Most of the images as saved from Visio as a .jpg or .png file. I found that images saved/encoded in .jpg from MSPaint typically worked as long as they were small. It also appears to be a DPI or image type of issues but it appears very inconsistent.

       

      Has anyone else had similar problems? For me it's a show stopper as I can't easily distributed a lot of content I'm creating at the moment in Clearspace.

       

      Cheers,

      Lukas

        • Re: Problems with Images in PDFs
          scott.hirdes

          Hi Lukas,

           

          I'm having trouble recreating this issue.  Just to confirm, you are creating a wiki document and putting an image in the document (something like !IMAGE_URL!) and then clicking the "View as PDF" link after publishing the document, correct?

           

          Can you provide some sample wiki document text that is causing you issues?

           

          thanks,

           

          Scott

            • Re: Problems with Images in PDFs

              Scott - I will PM you seperately with some images and content etc. It seems to be a very inconsistent issue, so hopefully you can gleam something from my tests.

               

              Also confirm what you are saying - that's exactly what I was doing.

                • Re: Problems with Images in PDFs
                  scott.hirdes

                  Hi,

                   

                  I still cannot recreate this issue.  Have you inspected your image settings in the admin console?  Do you have any settings set to limit the size or images or the number of images allowed?  You can view the image settings under System -> Settings -> Images.

                   

                  Cheers,

                   

                  Scott

                    • Re: Problems with Images in PDFs

                      Checked with the Admin here and that was the first thing he changed when I noticed the issues so it makes no difference.

                       

                      The admin today also cleared some caches, so I ran another test:

                       

                      I uploaded 6 images, inserted into a doc and published. Checkout out all fine in HTML. Then published to PDF and success - all turned up in the document. I then uploaded and inserted another two images. Check the html version - all fine. Then did the view as PDF and it didn't have the final two images. It only had the first 6.

                       

                      I then used a different order of pictures in a new document, but published in two parts again and had the same problem. So it seems to occur after the first view as PDF.

                       

                      Any thoughts or suggestions.... very strange!