1 Reply Latest reply on Oct 31, 2007 5:47 PM by scott.hirdes

    404 when trying to access documents (/docs)

      This is not really a question since I just found out what was causing the problem, just thought I'd share what caused the error. Having installed Clearspace 1.6.0 everything worked fine except creating/viewing documents. I got a 404-error from my application server (Tomcat 6) whenever I tried to view a document.

       

      The problem was that I tried to install clearspace as the root-application. Since there is a "docs"-folder in the home of tomcat, the server tried to access that folder instead of routing the call to clearspace. In think this folder was previously named tomcat-docs so this problem would not occur in tomcat5. Renaming/moving the folder solves the problem.

       

      I don't know whats the best way to make clearspace run as "root-application", using virtual hosts, using a frond-end server with a redirector that removes context path, etc?

       

      Another (completely different) thing that I found very useful during installation when synchronizing with LDAP was using an LDAP-browser to find out all the DN-strings.

       

      Thanks for reading =).