3 Replies Latest reply on Nov 21, 2007 10:34 AM by mikelcu

    XMPP Confusion

      That's the app's confusion, not mine (I think ).  The component connection between my CS and OF installs seems to be really off.  I just upgraded both today (1.8 and 3.4.1 respectively), and they're both functioning just fine alone.  Here are some descriptions of what's been happening now:

       

      - I edit Real-Time settings in CS, hit "Test Connection" and it works.  Save settings, hit "Start Connection" and it fails to connect.

      - Over on the OF instance, it shows the component as connected, so I delete the connection and start over.  Before I can touch CS, the component connection reappears in OF.  It still shows as disconnected in CS. This theme repeats over and over until I shut them both down. The connection shows up automatically and OF thinks CS has connected, CS thinks it has not.

      - I shut them both down.  Sort of. OF goes down easy.  CS won't die and I have to kill -9.

      - Start up OF, it show no connection (good).  Start up CS, it starts super slow (2min+) and I start getting this regularly:

      SEVERE: conflict

      org.xmpp.component.ComponentException: conflict

      - Connection shows up again in OF, but CS still thinks it is disconnected.

       

      I have no idea what's going on with this, but something is definitely out of whack.  Despite all the weirdness they both work nearly perfectly alone... Just when they try to talk things get weird.  Some data points:

       

      - I'm using LDAP for both instances, same source, same usernames,  jive.xmpp.commonUsernames  =    true

      - The domain shows up very oddly on the OF server: clearspace.clearspace.domain.com.openfire.domain.com.  (this is with OF @ openfire.domain.com and CS @ clearspace.domain.com)

      - One error that repears a lot is this in the OF debug.log:

      2007.11.16 14:26:19 Connect Socket[addr=/10.10.10.10,port=41695,localport=5275]

      2007.11.16 14:26:19 Starting registration of new external component for domain: clearspace.clearspace.domain.com

      2007.11.16 14:26:19 Another component is already using domain: clearspace.clearspace.domain.com.openfire.domain.com

      2007.11.16 14:26:19 Connection closed before session established

      Socket[addr=/10.10.10.10,port=41695,localport=5275]

       

      I'm stumped about this, any ideas would be greatly appreciated.

       

      TIA

       

      -Mike

        • Re: XMPP Confusion

          Well, I set up a new pair of instances  from scratch (OF 3.4.1, CS 1.8.0) and I stepped through testing presence while turning on LDAP and otherwise messing with their settings.  With the fresh installs, all works as expected, and I have both pointed to LDAP and presence is working. 

           

          This implies that the errors on my first instances are the result of something in the contents of the database since that is basically the only difference between the new and old installs (also, the new ones are using embedded, the originals are using postgres...).

           

          The question now is what could cause this and why?  If there is bad or invalid data in my databases, is there something that I can clear out manually? 

           

          -Mike

            • Re: XMPP Confusion
              scott.hirdes

              Hi Mike,

               

              Have you tried to remove the settings in Clearspace so that it does not try to connect to Openfire at all and then enter the settings again?

               

              thanks,

               

              Scott

                • Re: XMPP Confusion

                  Yeah, I've tried that.  The number of permutations of cause and effect is getting too big to list here, but the bottom line is that I can get presence to work for a bit, but most any type of disruption throws the whole thing into a tailspin, particularly if I have to restart clearspace, and still worse if clearspace does not shut down cleanly (which is often).     What I'd like to do is wipe out any and all non-essential data from my database (i.e. keep nothing but the content), and start over with an otherwise totally fresh install...

                   

                  -Mike