8 Replies Latest reply on Nov 5, 2015 1:21 PM by aperrotte

    Overriding Default CSS property

    gangadhareswara

      Hi,

       

      I tried to override some css properties in custom-css.ftl.But still it is not taking the properties which i have override instead of that it is taking the values which are coming from the default css(in my case(ui.css)). Is this right way or i have to follow some other way?

       

      Regards,

      Gangadhar

        • Re: Overriding Default CSS property
          Ryan Rutan

          This would be a great question for Amber Orenstein ... in theory you are doing it correctly; however, CSS rules can sometimes be tricky ... and that's just CSS.  Perhaps your selector isn't specific enough, or something else is interfering.  At a high-level, you are are approaching the problem in an appropriate way.  Can you share the element/properties you are trying to override, and what rules in ui.css are trumping your customizations.  Perhaps the answer lies in the details.

          • Re: Overriding Default CSS property
            aperrotte

            Gangahar,

             

            You might attempt adding !important after the element you're modifying. If this works, then as Ryan mentioned you might be fighting upstream against class inheritance or a myriad of other rules in CSS (display:block vs inline etc.) that may disallow your changes.

             

            I would suggest (obviously in your UAT) something simple like changing the main body background color.

             

            ex.

             

            #html,body {

                background-color: #332299;

                 }

             

            Doing this verifies that you have your theme mapped to the content you're expecting changes in. Remember any customized themes need to be mapped or applied globally to take effect.

             

            If simple changes to the background color do not take effect, it may be a mapping issue and have nothing to do with your CSS at all

             

            Sincerely,

            Aaron J. Perrotte

            1 person found this helpful
            • Re: Overriding Default CSS property
              Tim.Julius

              What version are you running? We are having a similar issue with 6.0.1.1, in which nothing from the custom_css.ftl is being loaded. We had a bunch of CSS changes made in 6.0.0.0 that worked without issue, but once we upgraded to 6.0.1.1, nothing gets loaded from the custom_css.ftl. There are no errors showing in our logs, nor the browsers development console.