15 Replies Latest reply on Jun 5, 2013 12:39 AM by sven.vetter

    Could not read from remote repository (error creating jiveapp)

    Brian.Welter

      I've been through all the steps many times and each time I keep getting stuck at the same point.

       

      When running the jiveapps create command, it gets stuck on step 3 of 4 with the error "Could not read from remote repository".

       

      Step 1 of 4. Checking availability and creating remote repository... SUCCESS

      Step 2 of 4. Generating app scaffolding...

        Enter App Title or hit enter for default [applytomsoe]:

        Enter App Description or hit enter for default [Description of applytomsoe]:

            create 

            create  javascripts

            create  stylesheets

            create  images

            create  app.xml

            create  canvas.html

            create  home.html

            create  hello.html

            create  stylesheets/main.css

            create  javascripts/main.js

            create  images/icon16.png

            create  images/icon48.png

            create  images/icon128.png

      Step 3 of 4. Creating local Git repository and pushing to remote... FAILURE

      W access for applytomsoe DENIED to brianwelter_Brian_Welters_iMac_local

      (Or there may be no repository at the given path. Did you spell it correctly?)

      fatal: Could not read from remote repository.

       

       

      Please make sure you have the correct access rights

      and the repository exists.

      Git Push failed. Deleting app and cleaning up. Check SSH key and try again:

       

       

      $ jiveapps keys:list

      $ jiveapps keys:remove <user@machine>

      $ jiveapps keys:add

      $ jiveapps create applytomsoe

       

      I've been through the steps for removing and recreating my ssh keys many times.

       

      Here's the output from the command   ssh -v -i ~/.ssh/id_rsa git@apphosting.jivesoftware.com

      OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011

      debug1: Reading configuration data /etc/ssh_config

      debug1: Connecting to apphosting.jivesoftware.com [204.93.64.228] port 22.

      debug1: Connection established.

      debug1: identity file /Users/brianwelter/.ssh/id_rsa type 1

      debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3

      debug1: match: OpenSSH_5.3 pat OpenSSH*

      debug1: Enabling compatibility mode for protocol 2.0

      debug1: Local version string SSH-2.0-OpenSSH_5.2

      debug1: SSH2_MSG_KEXINIT sent

      debug1: SSH2_MSG_KEXINIT received

      debug1: kex: server->client aes128-ctr hmac-md5 none

      debug1: kex: client->server aes128-ctr hmac-md5 none

      debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent

      debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP

      debug1: SSH2_MSG_KEX_DH_GEX_INIT sent

      debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

      debug1: Host 'apphosting.jivesoftware.com' is known and matches the RSA host key.

      debug1: Found key in /Users/brianwelter/.ssh/known_hosts:1

      debug1: ssh_rsa_verify: signature correct

      debug1: SSH2_MSG_NEWKEYS sent

      debug1: expecting SSH2_MSG_NEWKEYS

      debug1: SSH2_MSG_NEWKEYS received

      debug1: SSH2_MSG_SERVICE_REQUEST sent

      debug1: SSH2_MSG_SERVICE_ACCEPT received

      debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic

      debug1: Next authentication method: publickey

      debug1: Offering public key: /Users/brianwelter/.ssh/id_rsa

      debug1: Remote: Forced command: /home/git/bin/gl-auth-command brianwelter_Brian_Welters_iMac_local

      debug1: Remote: Port forwarding disabled.

      debug1: Remote: X11 forwarding disabled.

      debug1: Remote: Agent forwarding disabled.

      debug1: Remote: Pty allocation disabled.

      debug1: Server accepts key: pkalg ssh-rsa blen 277

      debug1: read PEM private key done: type RSA

      debug1: Remote: Forced command: /home/git/bin/gl-auth-command brianwelter_Brian_Welters_iMac_local

      debug1: Remote: Port forwarding disabled.

      debug1: Remote: X11 forwarding disabled.

      debug1: Remote: Agent forwarding disabled.

      debug1: Remote: Pty allocation disabled.

      debug1: Authentication succeeded (publickey).

      debug1: channel 0: new [client-session]

      debug1: Requesting no-more-sessions@openssh.com

      debug1: Entering interactive session.

      PTY allocation request failed on channel 0

      hello brianwelter_Brian_Welters_iMac_local, the gitolite version here is v2.0.2-0-g436662f

      the gitolite config gives you the following access:

           R   W msoe-appform

           R   W msoeapp

           R   W msoeapply

      debug1: client_input_channel_req: channel 0 rtype exit-status reply 0

      debug1: client_input_channel_req: channel 0 rtype eow@openssh.com reply 0

      debug1: channel 0: free: client-session, nchannels 1

      Connection to apphosting.jivesoftware.com closed.

      Transferred: sent 2496, received 3272 bytes, in 20.4 seconds

      Bytes per second: sent 122.4, received 160.4

      debug1: Exit status 0