4 Replies Latest reply on Jul 9, 2013 3:56 AM by keith.lawrence@groupm.com

    Problems Getting Started Creating "Hello World" App

    benhammond

      Hey, I'm new to the realm of Jive and trying to work my way through the Hello World tutorial. Since I'm behind a corporate firewall I have been forced to install cygwin and setup corkscrew. Unfortunately I'm still unable to create a new application without errors (or delete the erroneous ones!). This is what I'm seeing:

       

      $ jiveapps create testingwhatevergoaway3

      === Creating new Jive App "testingwhatevergoaway3"...

      Step 1 of 4. Checking availability and creating remote repository... SUCCESS

      Step 2 of 4. Generating app scaffolding...

      NOTE: Gem.cache is deprecated, use Gem::source_index. It will be removed on or after 2011-08-01.

      Gem.cache called from c:/Ruby192/lib/ruby/gems/1.9.1/gems/rubigen-1.5.5/lib/rubigen/lookup.rb:284

      .

        Enter App Title or hit enter for default [testingwhatevergoaway3]:

        Enter App Description or hit enter for default [Description of testingwhatevergoaway3]:

            create

            create  javascripts

            create  stylesheets

            create  images

            create  app.xml

            create  canvas.html

            create  home.html

            create  hello.html

            create  stylesheets/main.css

            create  javascripts/main.js

            create  images/icon16.png

            create  images/icon48.png

            create  images/icon128.png

      Step 3 of 4. Creating local Git repository and pushing to remote... FAILURE

      ssh_exchange_identification: Connection closed by remote host

      fatal: Could not read from remote repository.

       

       

      Please make sure you have the correct access rights

      and the repository exists.

      Git Push failed. Deleting app and cleaning up. Check SSH key and try again:

       

       

      $ jiveapps keys:list

      $ jiveapps keys:remove <user@machine>

      $ jiveapps keys:add

      $ jiveapps create testingwhatevergoaway3

      !   Errors:

       

       

       

      Any ideas? I'm not longer getting connection refused or timeouts so my working assumption is that my SSH proxy is running properly. Any help would be appreciated!