5 Replies Latest reply on Jun 5, 2013 5:26 AM by dfilip

    Dev Console Stopped Working - No Apps!

    dfilip

      The Dev Console on my development Jive instance (SBS 6.0) has stopped working.  The app will launch, and I will get the 'Loading ...' indicating that it is trying to load my apps at the top, but then nothing ever loads in (the 'Loading ...' disappears, but I'm let with whitespace, and no apps listed).

       

      If I click [Add App] and try to re-add the apps that were there, I get a green bar confirming that the app was loaded on the 'sandbox', but then the app does not appear.  I've tried both re-adding old apps (that were previously there) and new apps (that I never added before), and the same thing: no error, but no apps.

       

      If I check the box that says 'Install this app in my Quick Launcher', the app never gets added to the Quick Launcher.

       

      I have tried removing the Dev Console and then re-installing it, and the problem persists.

       

      Anyone have any ideas?  Has anyone else ever seen this Dev Console behavior before?  If I login as admin, go to the Admin Console, and click on the Apps tab, I have all green 'Success' lights, so my instance thinks it is talking to the app market, and I can install (other) new apps that work.

       

      Thanks,

       

      Dave.

        • Re: Dev Console Stopped Working - No Apps!
          jrenaud

          I've too seemed to suffer issues with the app market registration on our instances, where for some reason unknown to me app market id and other system properties 'jive.oauth.consumer_key' and 'jive.oauth.consumer_secret'.

           

          As this is a Dev instance, have you tried restarting it to see if the status is still displayed as registered properly with all green "sucess lights", and that you can still effectively browse the apps market as if you wanted to install new apps?

            • Re: Dev Console Stopped Working - No Apps!

              Dave,

              Thanks for dropping a note on the dev console. I've not hit this problem and just tried this a few minutes ago. It also sounds like there are no errors in the browser's console. I've asked Uttam Phalnikar to reach out and we may need to do a quick video call so we can share screens.

                • Re: Dev Console Stopped Working - No Apps!
                  dfilip

                  Thanks Mark!  Hopefully this can be done with a screen-sharing tool such as WebEx that will run on a Mac (i.e., NOT Microsoft LiveMeeting or something that only runs on PCs).  Currently, Jive is running on a Linux Virtual Machine hosted on a Mac (I use VMs for these types of projects so that I can move them around between servers and spin them up only when needed).

                   

                  Since the Dev Console worked last week, I am hoping that it shouldn't be too difficult to get working once again.

                    • Re: Dev Console Stopped Working - No Apps!

                      Dave Filip,

                      after working with Uttam Phalnikar it sounds like you are good to go. It seems there was a timeout error because of vm settings. Uttam Phalnikar, would you update this thread with the setting you changed?

                       

                       


                      bug-crusher.png
                      You squashed that bug dead!


                        • Re: Dev Console Stopped Working - No Apps!
                          dfilip

                          Kudos to Uttam Phalnikar for solving this!  The problem was that my Jive development server and/or network connection was too slow, so it was taking too long and timing out the connection.

                           

                          What probably happened is that I had other things running on the server at one point -- so it was a bit slower -- and then kept trying to [Add] apps to get them to show up in Dev Console ... after restarting Jive, after restarting the virtual server, after restarting the physical server, trying different apps, etc., so that I landed up making the problem much worse by adding many apps.  Turns out that every time I did that, it was successfully adding another app to the Market, which meant that it would then take even longer to retrieve the Market response!

                           

                          We edited .../WEB-INF/classes/jive-shindig.properties to change the time-out parameter from 13 seconds:

                           

                               shindig.http.client.connection-timeout-ms=13000

                           

                          to 30 seconds:

                           

                               shindig.http.client.connection-timeout-ms=30000

                           

                          and then re-started the server.  That then gave the Dev Console more time to retrieve the response.

                           

                          Suggestion: Please enhance Dev Console to display an appropriate message (e.g., Timed out downloading app from Market) rather than just displaying a blank area with no apps.

                           

                          Unfortunately, I still have problems with two of my logins, where I kept trying to [Add] apps, and am waiting for Uttam to clear those out of the Market for me, as I added so many apps that it is still taking more than 30 seconds to retrieve and process the response.