2 Replies Latest reply on Jun 11, 2013 11:49 AM by scottnoring

    Error installing the jive-sdk for Tiles

    scottnoring

      Anyone have any solutions or suggestions?


      Microsoft Windows [Version 6.2.9200]

       

       

      ...SampleTile2>npm install jive-sdk -g

      npm http GET https://registry.npmjs.org/jive-sdk

      npm http 304 https://registry.npmjs.org/jive-sdk

      npm http GET https://registry.npmjs.org/express/3.1.0

      npm http GET https://registry.npmjs.org/consolidate/0.9.0

      npm http GET https://registry.npmjs.org/q/0.9.3

      npm http GET https://registry.npmjs.org/underscore/1.4.4

      npm http GET https://registry.npmjs.org/request/2.16.6

      npm http GET https://registry.npmjs.org/mustache/0.7.2

      npm http GET https://registry.npmjs.org/mocha/1.9.0

      npm http GET https://registry.npmjs.org/optimist/0.4.0

      npm http GET https://registry.npmjs.org/mongojs/0.7.4

      npm http GET https://registry.npmjs.org/node-uuid/1.4.0

      npm http GET https://registry.npmjs.org/mongodb/1.2.14

      npm http GET https://registry.npmjs.org/fs-extra/0.6.0

      npm http GET https://registry.npmjs.org/log4js/0.6.3

      npm http GET https://registry.npmjs.org/xmlhttprequest

      npm http GET https://registry.npmjs.org/jquery

      npm http 304 https://registry.npmjs.org/consolidate/0.9.0

      npm http 304 https://registry.npmjs.org/express/3.1.0

      npm http 304 https://registry.npmjs.org/underscore/1.4.4

      npm http 304 https://registry.npmjs.org/request/2.16.6

      npm http 304 https://registry.npmjs.org/q/0.9.3

      npm WARN package.json consolidate@0.9.0 No repository field.

      npm http 304 https://registry.npmjs.org/mustache/0.7.2

      npm http 304 https://registry.npmjs.org/mocha/1.9.0

      npm http 304 https://registry.npmjs.org/optimist/0.4.0

      npm http 304 https://registry.npmjs.org/mongojs/0.7.4

      npm WARN package.json mustache@0.7.2 No repository field.

      npm http 304 https://registry.npmjs.org/node-uuid/1.4.0

      npm http 304 https://registry.npmjs.org/mongodb/1.2.14

      npm http 304 https://registry.npmjs.org/fs-extra/0.6.0

      npm http 304 https://registry.npmjs.org/log4js/0.6.3

      npm http 304 https://registry.npmjs.org/xmlhttprequest

      npm http 304 https://registry.npmjs.org/jquery

      npm WARN package.json fs-extra@0.6.0 homepage field must be a string url. Delete

      d.

      npm http GET https://registry.npmjs.org/thunky

      npm http GET https://registry.npmjs.org/readable-stream

      npm http GET https://registry.npmjs.org/jsonfile

      npm http GET https://registry.npmjs.org/ncp

      npm http GET https://registry.npmjs.org/mkdirp

      npm http GET https://registry.npmjs.org/rimraf

      npm http GET https://registry.npmjs.org/wordwrap

      npm http GET https://registry.npmjs.org/connect/2.7.2

      npm http GET https://registry.npmjs.org/commander/0.6.1

      npm http GET https://registry.npmjs.org/range-parser/0.0.4

      npm http GET https://registry.npmjs.org/mkdirp/0.3.3

      npm http GET https://registry.npmjs.org/cookie/0.0.5

      npm http GET https://registry.npmjs.org/buffer-crc32/0.1.1

      npm http GET https://registry.npmjs.org/fresh/0.1.0

      npm http GET https://registry.npmjs.org/methods/0.0.1

      npm http GET https://registry.npmjs.org/send/0.1.0

      npm http GET https://registry.npmjs.org/cookie-signature/0.0.1

      npm http GET https://registry.npmjs.org/debug

      npm http GET https://registry.npmjs.org/mime

      npm http GET https://registry.npmjs.org/form-data

      npm http GET https://registry.npmjs.org/cookie-jar

      npm http GET https://registry.npmjs.org/aws-sign

      npm http GET https://registry.npmjs.org/oauth-sign

      npm http GET https://registry.npmjs.org/forever-agent

      npm http GET https://registry.npmjs.org/tunnel-agent

      npm http GET https://registry.npmjs.org/json-stringify-safe

      npm http GET https://registry.npmjs.org/qs

      npm http GET https://registry.npmjs.org/hawk

      npm http 304 https://registry.npmjs.org/thunky

      npm http GET https://registry.npmjs.org/dequeue/1.0.3

      npm http GET https://registry.npmjs.org/async/0.1.15

      npm http GET https://registry.npmjs.org/semver

      npm http GET https://registry.npmjs.org/growl

      npm http GET https://registry.npmjs.org/htmlparser/1.7.6

      npm http GET https://registry.npmjs.org/jade/0.26.3

      npm http GET https://registry.npmjs.org/diff/1.0.2

      npm http GET https://registry.npmjs.org/location/0.0.1

      npm http GET https://registry.npmjs.org/jsdom

      npm http GET https://registry.npmjs.org/contextify

      npm http GET https://registry.npmjs.org/navigator

      npm http GET https://registry.npmjs.org/ms/0.3.0

      npm http 304 https://registry.npmjs.org/readable-stream

      npm http 304 https://registry.npmjs.org/rimraf

      npm http 304 https://registry.npmjs.org/mkdirp

      npm http GET https://registry.npmjs.org/bson/0.1.8

      npm http 304 https://registry.npmjs.org/wordwrap

      npm http 304 https://registry.npmjs.org/connect/2.7.2

      npm http 304 https://registry.npmjs.org/ncp

      npm http 304 https://registry.npmjs.org/jsonfile

      npm WARN package.json jsonfile@0.0.1 homepage field must be a string url. Delete

      d.

      npm http 304 https://registry.npmjs.org/commander/0.6.1

      npm http 304 https://registry.npmjs.org/range-parser/0.0.4

      npm http 304 https://registry.npmjs.org/mkdirp/0.3.3

      npm http 304 https://registry.npmjs.org/cookie/0.0.5

      npm http 304 https://registry.npmjs.org/buffer-crc32/0.1.1

      npm WARN package.json range-parser@0.0.4 No repository field.

      npm http 304 https://registry.npmjs.org/fresh/0.1.0

      npm WARN package.json fresh@0.1.0 No repository field.

      npm http GET https://registry.npmjs.org/graceful-fs

      npm http 304 https://registry.npmjs.org/methods/0.0.1

      npm http 304 https://registry.npmjs.org/send/0.1.0

      npm http 304 https://registry.npmjs.org/cookie-signature/0.0.1

      npm http 304 https://registry.npmjs.org/debug

      npm http 304 https://registry.npmjs.org/mime

      npm WARN package.json methods@0.0.1 No repository field.

      npm WARN package.json methods@0.0.1 No readme data.

      npm WARN package.json send@0.1.0 No repository field.

      npm WARN package.json cookie-signature@0.0.1 No repository field.

      npm http 304 https://registry.npmjs.org/form-data

      npm http 304 https://registry.npmjs.org/cookie-jar

      npm http 304 https://registry.npmjs.org/forever-agent

      npm http 304 https://registry.npmjs.org/aws-sign

      npm http 304 https://registry.npmjs.org/oauth-sign

      npm WARN package.json cookie-jar@0.2.0 No readme data.

      npm WARN package.json forever-agent@0.2.0 No readme data.

      npm WARN package.json aws-sign@0.2.0 No readme data.

      npm WARN package.json oauth-sign@0.2.0 No readme data.

      npm http 304 https://registry.npmjs.org/tunnel-agent

      npm http 304 https://registry.npmjs.org/json-stringify-safe

      npm http 304 https://registry.npmjs.org/qs

      npm http 304 https://registry.npmjs.org/hawk

      npm http 304 https://registry.npmjs.org/dequeue/1.0.3

      npm WARN package.json tunnel-agent@0.2.0 No readme data.

      npm WARN engine hawk@0.10.2: wanted: {"node":"0.8.x"} (current: {"node":"v0.10.1

      0","npm":"1.2.25"})

      npm http 304 https://registry.npmjs.org/async/0.1.15

      npm http 304 https://registry.npmjs.org/semver

      npm http 304 https://registry.npmjs.org/growl

      npm http 304 https://registry.npmjs.org/htmlparser/1.7.6

      npm http 304 https://registry.npmjs.org/jade/0.26.3

      npm WARN package.json jade@0.26.3 No readme data.

      npm WARN package.json growl@1.7.0 No repository field.

      npm http GET https://registry.npmjs.org/mime/1.2.6

      npm http 304 https://registry.npmjs.org/location/0.0.1

      npm http 304 https://registry.npmjs.org/diff/1.0.2

      npm http 304 https://registry.npmjs.org/jsdom

      npm http 304 https://registry.npmjs.org/contextify

      npm http 304 https://registry.npmjs.org/navigator

      npm http 304 https://registry.npmjs.org/ms/0.3.0

      npm WARN package.json jsdom@0.2.19 No repository field.

      npm WARN package.json jsdom@0.2.19 'repositories' (plural) Not supported.

      npm WARN package.json Please pick one as the 'repository' field

      npm http 304 https://registry.npmjs.org/graceful-fs

      npm http 304 https://registry.npmjs.org/bson/0.1.8

      npm http 304 https://registry.npmjs.org/mime/1.2.6

      npm WARN package.json ms@0.3.0 No repository field.

      npm http GET https://registry.npmjs.org/combined-stream

      npm http GET https://registry.npmjs.org/async

      npm http GET https://registry.npmjs.org/bindings

      npm http GET https://registry.npmjs.org/boom

      npm http GET https://registry.npmjs.org/hoek

      npm http GET https://registry.npmjs.org/cryptiles

      npm http GET https://registry.npmjs.org/sntp

      npm http 304 https://registry.npmjs.org/combined-stream

      npm http 304 https://registry.npmjs.org/async

      npm http 304 https://registry.npmjs.org/cryptiles

      npm http 304 https://registry.npmjs.org/sntp

      npm http GET https://registry.npmjs.org/mkdirp/0.3.0

      npm http GET https://registry.npmjs.org/cssom

      npm http GET https://registry.npmjs.org/cssstyle

      npm http 304 https://registry.npmjs.org/bindings

       

      > contextify@0.1.5 install C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-

      sdk\node_modules\jquery\node_modules\contextify

      > node-gyp rebuild

       

       

      C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modules\jquery\nod

      e_modules\contextify>node "C:\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\no

      de_modules\node-gyp\bin\node-gyp.js" rebuild

      npm http 304 https://registry.npmjs.org/cssstyle

      npm http 304 https://registry.npmjs.org/hoek

      npm http 304 https://registry.npmjs.org/boom

      npm WARN engine cryptiles@0.1.3: wanted: {"node":"0.8.x"} (current: {"node":"v0.

      10.10","npm":"1.2.25"})

      npmgyp  WARN ERR!engine  sntp@0.1.4: wanted: {"node":"0.8.x"} (current: {"node":

      "v0.10.10","npm":"1.2.25"})

      configure error

      gyp npm ERR!WARN  stackengine hoek@0.7.6: wanted: {"node":"0.8.x"} (current: {"n

      ode":"v0.10.10","npm":"1.2.25"})

      Error: Can't find Python executable "python", you can set the PYTHON env variab

      le.

      gyp ERR! stacknpm     at failNoPython (C:\nodejs\node_modules\npm\node_modules\n

      ode-gyp\lib\configure.js:113:14)

      WARNgyp  engineERR! boom@0.3.8: wanted: {"node":"0.8.x"} (current: {"node":"v0.

      10.10","npm":"1.2.25"})

      stack     at C:\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:

      81:11

      gyp ERR! stack     at Object.oncomplete (fs.js:107:15)

      gyp ERR! System Windows_NT 6.2.9200

      gyp ERR! command "node" "C:\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\

      bin\\node-gyp.js" "rebuild"

      gyp ERR! cwd C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modul

      es\jquery\node_modules\contextify

      gyp ERR! node -v v0.10.10

      gyp ERR! node-gyp -v v0.9.6

      gyp ERR! not ok

      npm http GET https://registry.npmjs.org/delayed-stream/0.0.5

      npm http 304 https://registry.npmjs.org/cssom

      npm ERR! Error: ENOENT, chmod 'C:\Users\Scott\AppData\Roaming\npm\node_modules\j

      ive-sdk\node_modules\jquery\node_modules\htmlparser\.settings\org.eclipse.wst.js

      dt.ui.superType.container'

      npm ERR! If you need help, you may report this log at:

      npm ERR!     <http://github.com/isaacs/npm/issues>

      npm ERR! or email it to:

      npm ERR!     <npm-@googlegroups.com>

       

      npm ERR! System Windows_NT 6.2.9200

      npm ERR! command "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\n

      pm-cli.js" "install" "jive-sdk" "-g"

      npm ERR! cwd C:\Users\Scott\workspace\GIT\SampleTile2

      npm ERR! node -v v0.10.10

      npm ERR! npm -v 1.2.25

      npm ERR! path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modu

      les\jquery\node_modules\htmlparser\.settings\org.eclipse.wst.jsdt.ui.superType.c

      ontainer

      npm ERR! fstream_path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\n

      ode_modules\jquery\node_modules\htmlparser\.settings\org.eclipse.wst.jsdt.ui.sup

      erType.container

      npm ERR! fstream_type File

      npm ERR! fstream_class FileWriter

      npm ERR! fstream_finish_call chmod

      npm ERR! code ENOENT

      npm ERR! errno 34

      npm ERR! fstream_stack C:\nodejs\node_modules\npm\node_modules\fstream\lib\write

      r.js:305:19

      npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

      npm http 304 https://registry.npmjs.org/mkdirp/0.3.0

      npm ERR! error rolling back Error: ENOTEMPTY, rmdir 'C:\Users\Scott\AppData\Roam

      ing\npm\node_modules\jive-sdk\node_modules\jquery\node_modules\jsdom'

      npm ERR! error rolling back  jquery@1.8.3 { [Error: ENOTEMPTY, rmdir 'C:\Users\S

      cott\AppData\Roaming\npm\node_modules\jive-sdk\node_modules\jquery\node_modules\

      jsdom']

      npm ERR! error rolling back   errno: 53,

      npm ERR! error rolling back   code: 'ENOTEMPTY',

      npm ERR! error rolling back   path: 'C:\\Users\\Scott\\AppData\\Roaming\\npm\\no

      de_modules\\jive-sdk\\node_modules\\jquery\\node_modules\\jsdom' }

      npm http 304 https://registry.npmjs.org/delayed-stream/0.0.5

      npm ERR! Error: ENOENT, chmod 'C:\Users\Scott\AppData\Roaming\npm\node_modules\j

      ive-sdk\node_modules\mocha\node_modules\jade\node_modules\mkdirp\.gitignore.rej'

       

      npm ERR! If you need help, you may report this log at:

      npm ERR!     <http://github.com/isaacs/npm/issues>

      npm ERR! or email it to:

      npm ERR!     <npm-@googlegroups.com>

       

      npm ERR! System Windows_NT 6.2.9200

      npm ERR! command "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\n

      pm-cli.js" "install" "jive-sdk" "-g"

      npm ERR! cwd C:\Users\Scott\workspace\GIT\SampleTile2

      npm ERR! node -v v0.10.10

      npm ERR! npm -v 1.2.25

      npm ERR! path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modu

      les\mocha\node_modules\jade\node_modules\mkdirp\.gitignore.rej

      npm ERR! fstream_path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\n

      ode_modules\mocha\node_modules\jade\node_modules\mkdirp\.gitignore.rej

      npm ERR! fstream_type File

      npm ERR! fstream_class FileWriter

      npm ERR! fstream_finish_call chmod

      npm ERR! code ENOENT

      npm ERR! errno 34

      npm ERR! fstream_stack C:\nodejs\node_modules\npm\node_modules\fstream\lib\write

      r.js:305:19

      npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

      npm ERR! error rolling back Error: ENOTEMPTY, rmdir 'C:\Users\Scott\AppData\Roam

      ing\npm\node_modules\jive-sdk\node_modules\mongodb\node_modules\bson\test\browse

      r'

      npm ERR! error rolling back  jive-sdk@0.0.75 { [Error: ENOTEMPTY, rmdir 'C:\User

      s\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modules\mongodb\node_modu

      les\bson\test\browser']

      npm ERR! error rolling back   errno: 53,

      npm ERR! error rolling back   code: 'ENOTEMPTY',

      npm ERR! error rolling back   path: 'C:\\Users\\Scott\\AppData\\Roaming\\npm\\no

      de_modules\\jive-sdk\\node_modules\\mongodb\\node_modules\\bson\\test\\browser'

      }

      npm ERR! weird error 1

      npm ERR! Error: ENOENT, lstat 'C:\Users\Scott\AppData\Roaming\npm\node_modules\j

      ive-sdk\node_modules\request\node_modules\hawk\node_modules\hoek\lib\index.js'

      npm ERR! If you need help, you may report this log at:

      npm ERR!     <http://github.com/isaacs/npm/issues>

      npm ERR! or email it to:

      npm ERR!     <npm-@googlegroups.com>

       

      npm ERR! System Windows_NT 6.2.9200

      npm ERR! command "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\n

      pm-cli.js" "install" "jive-sdk" "-g"

      npm ERR! cwd C:\Users\Scott\workspace\GIT\SampleTile2

      npm ERR! node -v v0.10.10

      npm ERR! npm -v 1.2.25

      npm ERR! path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modu

      les\request\node_modules\hawk\node_modules\hoek\lib\index.js

      npm ERR! fstream_path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\n

      ode_modules\request\node_modules\hawk\node_modules\hoek\lib\index.js

      npm ERR! fstream_type File

      npm ERR! fstream_class FileWriter

      npm ERR! code ENOENT

      npm ERR! errno 34

      npm ERR! fstream_stack C:\nodejs\node_modules\npm\node_modules\fstream\lib\write

      r.js:284:26

      npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

      npm ERR! Error: ENOENT, lstat 'C:\Users\Scott\AppData\Roaming\npm\node_modules\j

      ive-sdk\node_modules\mongodb\node_modules\bson\test\browser\nodeunit.js'

      npm ERR! If you need help, you may report this log at:

      npm ERR!     <http://github.com/isaacs/npm/issues>

      npm ERR! or email it to:

      npm ERR!     <npm-@googlegroups.com>

       

      npm ERR! System Windows_NT 6.2.9200

      npm ERR! command "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\n

      pm-cli.js" "install" "jive-sdk" "-g"

      npm ERR! cwd C:\Users\Scott\workspace\GIT\SampleTile2

      npm ERR! node -v v0.10.10

      npm ERR! npm -v 1.2.25

      npm ERR! path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modu

      les\mongodb\node_modules\bson\test\browser\nodeunit.js

      npm ERR! fstream_path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\n

      ode_modules\mongodb\node_modules\bson\test\browser\nodeunit.js

      npm ERR! fstream_type File

      npm ERR! fstream_class FileWriter

      npm ERR! code ENOENT

      npm ERR! errno 34

      npm ERR! fstream_stack C:\nodejs\node_modules\npm\node_modules\fstream\lib\write

      r.js:284:26

      npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

      npm ERR! Error: ENOENT, lstat 'C:\Users\Scott\AppData\Roaming\npm\node_modules\j

      ive-sdk\node_modules\jquery\node_modules\jsdom\node_modules\cssstyle\lib\CSSStyl

      eDeclaration.js'

      npm ERR! If you need help, you may report this log at:

      npm ERR!     <http://github.com/isaacs/npm/issues>

      npm ERR! or email it to:

      npm ERR!     <npm-@googlegroups.com>

       

      npm ERR! System Windows_NT 6.2.9200

      npm ERR! command "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\n

      pm-cli.js" "install" "jive-sdk" "-g"

      npm ERR! cwd C:\Users\Scott\workspace\GIT\SampleTile2

      npm ERR! node -v v0.10.10

      npm ERR! npm -v 1.2.25

      npm ERR! path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modu

      les\jquery\node_modules\jsdom\node_modules\cssstyle\lib\CSSStyleDeclaration.js

      npm ERR! fstream_path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\n

      ode_modules\jquery\node_modules\jsdom\node_modules\cssstyle\lib\CSSStyleDeclarat

      ion.js

      npm ERR! fstream_type File

      npm ERR! fstream_class FileWriter

      npm ERR! code ENOENT

      npm ERR! errno 34

      npm ERR! fstream_stack C:\nodejs\node_modules\npm\node_modules\fstream\lib\write

      r.js:284:26

      npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

      npm ERR! Error: ENOENT, lstat 'C:\Users\Scott\AppData\Roaming\npm\node_modules\j

      ive-sdk\node_modules\express\node_modules\connect\lib\public\icons\page_white_tu

      x.png'

      npm ERR! If you need help, you may report this log at:

      npm ERR!     <http://github.com/isaacs/npm/issues>

      npm ERR! or email it to:

      npm ERR!     <npm-@googlegroups.com>

       

      npm ERR! System Windows_NT 6.2.9200

      npm ERR! command "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\n

      pm-cli.js" "install" "jive-sdk" "-g"

      npm ERR! cwd C:\Users\Scott\workspace\GIT\SampleTile2

      npm ERR! node -v v0.10.10

      npm ERR! npm -v 1.2.25

      npm ERR! path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\node_modu

      les\express\node_modules\connect\lib\public\icons\page_white_tux.png

      npm ERR! fstream_path C:\Users\Scott\AppData\Roaming\npm\node_modules\jive-sdk\n

      ode_modules\express\node_modules\connect\lib\public\icons\page_white_tux.png

      npm ERR! fstream_type File

      npm ERR! fstream_class FileWriter

      npm ERR! code ENOENT

      npm ERR! errno 34

      npm ERR! fstream_stack C:\nodejs\node_modules\npm\node_modules\fstream\lib\write

      r.js:284:26

      npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

      npm ERR!

      npm ERR! Additional logging details can be found in:

      npm ERR!     C:\Users\Scott\workspace\GIT\SampleTile2\npm-debug.log

      npm ERR! not ok code 0

      C:\Users\Scott\workspace\GIT\SampleTile2>