2 Replies Latest reply on Aug 25, 2013 5:42 PM by hitesh.mathpal

    Errors in JIVE Apps

    hitesh.mathpal

      Hi, I am creating a JIVE app using Open Social API. I am facing several issues.  I am feeling the gadget framework of JIVE  has a lots of issues as well . Here are some points-

      1. app.xml is not updating properly. I have deleted "action-contributions" and uploaded the new app.xml file but its still taking the old one. I have uninstalled and installed the app several times. I have pushed new app.xml in various time intervals but everytime it says the same. The error is -Action contribution errors  . One thing that I guess is - JIVE is not deleting my action contributers once they are made. If I delete them in app.xml it doesn't update. (I have tested this several times).
      2. Even if the app is installed it says -"{"error":{"message":"Cannot render an application without installing it first","code":403},"status":403}" The wonder -  it was working before. I just did some changes in my view (Some HTML changes only).
      3. While I am deleting app from app console it deletes the app but says message "Error !". Also I can not create the app by same name. (Even after 1 day ).
      4. It happens many time while I create a new app by using the command "Jiveapps create <myAppName>" it doesn't work (Same for deleting as well).

       

      Any help will be appreciated !

        • Re: Errors in JIVE Apps

          Hitesh,

          There should be a small circular arrow on the top right of the app's chrome. This will force a refresh of all the assets.

           

          Uttam Phalnikar

          Would you elaborate on what causes the error message:

           

          Even if the app is installed it says -"{"error":{"message":"Cannot render an application without installing it first","code":403},"status":403}" The wonder -  it was working before. I just did some changes in my view (Some HTML changes only).

           

           

          The deleting of the app should not error out. I suspect that in the manipulation of the app, somehow you got into a funny state where Jive thinks the app is uninstalled but it's not. This could be b/c it's the sandbox and we use a special loading algorithm there.

           

          The jiveapps command line tool should be fixed. However, we'll be pushing a new version of the apps market that makes it possible for you to create and host your own applications, without using the jiveapps infrastructure. You'll be able to do this from here: https://developers.jivesoftware.com/jiveapps

            • Re: Errors in JIVE Apps
              hitesh.mathpal

              Hi Mark, Mark Weitzel

              Thanks for your response.Here are some findings from our end-

              1. We resolved error "{"error":{"message":"Cannot render an application without installing it first","code":403},"status":403}". This is because of some Javascript exception. Actually while we were pushing content from app to a JS method (which was using opensocial) , this error occurs. It was a JS syntactical error. Error message confused me because two views of the app were successfully working. Only one view which was using that JS was giving that problem.
              2. For Action contribution errors , I will use force refresh option further. This time I have deleted the app and created a new one.
              3. App deletion is still showing errors. Actually we want to use the name of our app which we created and deleted then. It says - "This name is in use".

               

              We are still working on our apps and will keep posting our findings and issues. Thanks for your support and replies.

               

              Cheers !