3 Replies Latest reply on Oct 9, 2013 8:55 AM by matthewj

    Tasks search API doesn't work?

    matthewj

      I've been trying for several days to get the tasks search API to work but I always get the error "The sort parameter is invalid. Available parameters are: created_at,updated_at,project,creator,deadline_time,priority,status,title,_score".

       

      I've tried using the example from the documentation using cURL but changing the JSON slightly to:

       

      curl -v -X POST --data '{ "networks":[], "projects":["1234"], "priorities":[4, 5], "statuses":[0], "responsibles":[],"creators":[], "labels":[], "deadline":{}, "created_at":{}, "updated_at":{}, "search":{}}' "https://www.producteev.com/api/tasks/search" --header "Content-Type:application/json" --header "Authorization:Bearer 5Fm-kYL08PpPU3VkYzTbCNO3-Ldzk8-COtjp3_7Xmto"

       

      Where 1234 is my project ID and also changing the token to my own.

       

      I've also tried using PHP and cURL and sending the following JSON.

       

      {"networks":[],"projects":["524c2a9e73019b9518000003"],"priorities":[4, 5],"statuses":[0],"responsibles":[],"creators":[],"labels":[],"deadline":{},"created_at":{},"updated_at":{},"search":{},"sort":{"project"}}