8 Replies Latest reply on Oct 20, 2013 10:37 AM by cmccann

    can't even run jiveapps create ...

    jdvande

      so in preparation for jiveworld I'm doing the homework assignment. 

      Creation of the developer account went fine.  it even appears to have been properly linked to my pre-existing jive community account. (at least so I'm assuming since loging into the sandbox used the exact same username and password.

      installation of git and ruby went flawlessly.

      however when I run

      jiveapps create <myapp>
      

       

      I get an endless loop of :

      Authentication failure
      Enter your Jive Apps Developer Community credentials. (https://developers.jivesoftware.com)
      Username: <username>
      Password: 
      
      

       

      anyone else run into this?

        • Re: can't even run jiveapps create ...
          shanna

          I am running into exactly the same problem. I had a jive account already. I can access the Jive Support Community, Jive Developers Community and Jive Sandbox just fine via the browser. But when I run jiveapps create, it can't authenticate (same error as above).

           

          I used the #enrollment link as Arnold specified. When I filled out the form, it says my username had already been taken. When I changed the username to a unique one, it says the email address had already been taken. Clearly, the username and email address are taken because I already registered. So if I am registered, why can't jiveapps create authenticate my developers community credentials?

            • Re: can't even run jiveapps create ...

              Ran into the same situation when they switched over auth a while back. Basically I have two separate accounts with distinct usernames and email addresses now

               

              Sent from my Windows Phone

              • Re: can't even run jiveapps create ...
                shanna

                I just went into develops.jivesoftware.com to change my password and log in using the new password via the browser. Everything works fine. Yet, when I run jiveapps create in Git Bash, it failed to authenticate. (Authentication failure) I am at a lost.

                • Re: can't even run jiveapps create ...
                  shanna

                  I took Nil's suggestion and created an account with unique username AND email address. That got me further. "jiveapps create" at least authenticates correctly now but it now complains about Git Push failed. Once it fails, you can't create the app with the same name anymore. Not even after you run "jiveapps delete <name>". "jiveapps delete" simply return "Error: " with no further information. This process is starting to feel like it's held together with duct tapes.

                   

                  Errors for "jiveapps create" ...

                   

                  $ jiveapps create xchange2

                  c:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require':

                  iconv will be deprecated in the future, use String#encode instead.

                  c:/Ruby193/lib/ruby/gems/1.9.1/gems/systemu-2.2.0/lib/systemu.rb:29: Use RbConfi

                  g instead of obsolete and deprecated Config.

                  === Creating new Jive App "xchange2"...

                  Step 1 of 4. Checking availability and creating remote repository... SUCCESS

                  Step 2 of 4. Generating app scaffolding...

                  NOTE: Gem.cache is deprecated, use Gem::source_index. It will be removed on or a

                  fter 2011-08-01.

                  Gem.cache called from c:/Ruby193/lib/ruby/gems/1.9.1/gems/rubigen-1.5.5/lib/rubi

                  gen/lookup.rb:284.

                  NOTE: Gem.source_index is deprecated, use Specification. It will be removed on o

                  r after 2011-11-01.

                  Gem.source_index called from c:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems.rb:117

                  5.

                  NOTE: Gem::SourceIndex#each is deprecated with no replacement. It will be remove

                  d on or after 2011-11-01.

                  Gem::SourceIndex#each called from c:/Ruby193/lib/ruby/gems/1.9.1/gems/rubigen-1.

                  5.5/lib/rubigen/lookup.rb:284.

                    Enter App Title or hit enter for default [xchange2]:

                    Enter App Description or hit enter for default [Description of xchange2]:

                        create

                        create  javascripts

                        create  stylesheets

                        create  images

                        create  app.xml

                        create  canvas.html

                        create  home.html

                        create  hello.html

                        create  stylesheets/main.css

                        create  javascripts/main.js

                        create  images/icon16.png

                        create  images/icon48.png

                        create  images/icon128.png

                  Step 3 of 4. Creating local Git repository and pushing to remote... FAILURE

                  Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

                  fatal: Could not read from remote repository.

                   

                   

                  Please make sure you have the correct access rights

                  and the repository exists.

                  Git Push failed. Deleting app and cleaning up. Check SSH key and try again:

                   

                   

                  $ jiveapps keys:list

                  $ jiveapps keys:remove <user@machine>

                  $ jiveapps keys:add

                  $ jiveapps create xchange2

                  !   Errors:

                • Re: can't even run jiveapps create ...
                  gdinning

                  I had a similar problem initially.  It seemed that the going through the registration link given in the email didn't actually register me.  I can't remember exactly what I did, but I think I went to the Developers page and registered from there.  After that, I was able to go in with my usual username and password.

                   

                  Try registering at https://developers.jivesoftware.com/register.jsp.  Hopefully that will do the trick.