0 Replies Latest reply on Feb 9, 2008 1:06 PM by gmwnet

    Upgrade stuck on group mapping, now database seems bad

       

      We had a very successful test of clearspace -- even had the database in MSSQL and it all was great.  The clearspace test server was linux with MSSQL on win2k3 of course.  AD LDAP integration worked  -- even had it connected to openfire. Everything worked great.  Until...

       

       

      For production we migrated to using Windows2003 server for the clearspace server as that's the hardware we have available.  Actually installed clearspace successfully on this server using a separate test MSSQL database. So after that I uninstalled the clearspace on this new production server, deleted the old jivehome directory, and re-started another fresh install so I could move the application to using the production DB that the test server had been using.  Started the windows installer of 1.10.1  Everything proceded smoothly until the group mapping setup step -- here it hung.  We are using AD LDAP for user authentication and all those tests worked great.  Used the MSSQL database that the testing box used and that connection tested great, just as before.  The old testing server is shutdown.  But no matter which option under group mapping I try to use (LDAP or internal) the setup step just hangs.  Times-out.  Stops.

       

       

      After a day of futile work I decide to come back later and try again -- so I go and re-start the testing instance of clearspace we had working on the linux box so at least we can access the data on it -- and lo and behold, it doesn't work now either!  I restore the database from a previous known good version -- nope!    We are stuck.  No combination of database/clearspace server or anything will get us beyond the group mapping setup stage and into a working clearspace.

       

       

      I can install a completely new version with a new database on all this equipment and it works fine.  So all the peices are talking properly.  I cannot get any instance to use the database we used previously.  If there was a way to import the data from one database into another that would solve my problems. 

       

       

      Please tell me, oh clearspace gurus, there is some way we can re-gain the past 3 months of work stuck in a perfectly functioning SQL server database!

       

       

      Thanks!

       

       

      -Garrett