9 Replies Latest reply on Aug 7, 2014 1:42 PM by happysridhar

    Jive 7 plugin i18n properties issue

    cmschofield

      We are currently migrating a plugin from Jive 6 to Jive 7 and one issue we're dealing with is the i18n.properties files we use are not being loaded. Thus, all references to our i18n properties within our plugin are only showing the key and not the key value. The plugin builds properly in maven and gets installed as normal (the properties files are copied to the CLASSES directory) but the localizations just don't show up. Any suggestions and resolving this? If you've experienced this in earlier Jive versions, I'd be interested in those solutions also.

       

      ~Thank you!

        • Re: Jive 7 plugin i18n properties issue
          kshaw79

          Chris,

           

          I doubt this will help, but with Jive 4, 5 and 6 I always rename the i18n.properties files to include the two letter language code.  For english, I use plugin_i18n_en.properties.

           

          Cheers,

          Keith

            • Re: Jive 7 plugin i18n properties issue
              cmschofield

              Hi Keith,

               

              Thanks for your suggestion. I did attempt that to no avail. We've also tried moving the properties files to different directories, as well as reviewing the plugin.xml to see if any changes are needed, but we aren't seeing any at this point.

               

              I'll keep reading documentation and attempting other solutions to see if we can figure something out. Thank you again for your response.

               

              ~Chris

            • Re: Jive 7 plugin i18n properties issue
              cmschofield

              Bumping. We are still having this issue without resolution. Any thoughts would be much appreciated.

                • Re: Jive 7 plugin i18n properties issue
                  jgotti

                  This does not work for me either Daniel Neumann do you have any suggestions?

                   

                  I tried playing with the "# smartling.placeholder_format = NONE" which did not help either

                    • Re: Jive 7 plugin i18n properties issue

                      Hi there.

                       

                      The smartling.placeholder_format tag within the localization files has no effect in how the files behave within Jive systems. It is purely related to the system where the translations are being run, so playing with it won't affect (positively not negatively).

                       

                      As far as I know there hasn't been architectural changes that could affect to the point of breaking existing localization.

                       

                      Have you filed a case for this? you might need a developer who can tell a bit more from the architectural or build standpoint and see if changes are needed elsewhere.

                       

                      So far, the actual i18n files haven't changed at all (other than new/changed key-values) from Jive 6 to 7.

                  • Re: Jive 7 plugin i18n properties issue
                    cmschofield

                    We have resolved this error by changing the <name> node in the plugin.xml from CamelCase name to lowercase name (we decided to change the name in Jive 7). Subsequently, we've also lowercased all plugin name references in the pom.xml (not sure if that is necessary). We found this out by looking at com.jivesoftware.base.plugin.PluginUtils.extractPlugin() and found that the plugin name is lowercased when creating the plugin directory. The plugin would install fine in our Windows dev environments, but on Mac OS we had install failures and I was able to troubleshoot from there.

                     

                    What's interesting is Jive attempts to take into account case-insensitive file systems in the same extractPlugin() method. Yet, when it reads the plugin name from the plugin configuration, it doesn't lowercase it and then compares the names to determine if it needs to delete the directory. The jivehome/plugin/[plugin name] directory was being deleted, and thus Jive would error out when it couldn't find the plugin directory.

                     

                    In the end, lowercase your plugin name in the plugin.xml file.

                      • Re: Jive 7 plugin i18n properties issue

                        Thank you for posting! I was wondering what was going on ...

                          • Re: Jive 7 plugin i18n properties issue
                            happysridhar

                            Hi, I made few changes to i18n_en_ properties fils and tested in my windows local system every thing seems working find. how ever when I try to deploy the WAR on CentOS (VM ) I am getting error and server never come up

                            Traceback (most recent call last):

                              File "/usr/local/jive/python/bin/jive", line 9, in <module>

                                load_entry_point('jive-cli==1.1.3', 'console_scripts', 'jive')()

                              File "/usr/local/jive/python/lib/python2.7/site-packages/jive_cli/jive.py", line 88, in main

                                parser.add_argument('--version', action='version', version=get_version_string(APPARENT_JIVE_HOME))

                              File "/usr/local/jive/python/lib/python2.7/site-packages/jive_cli/jive.py", line 61, in get_version_string

                                versions.append('jive_war_manifest={}-{}'.format(vals.get('Implementation-Version').strip(),

                            AttributeError: 'NoneType' object has no attribute 'strip'

                             

                            Any suggestions in resolving this?