3 Replies Latest reply on Sep 3, 2014 12:58 PM by mikhalchuk

    Including an image in a DM

    schennamaraja

      Hi,

       

      I'm trying to post a DM via REST API and include a Google Analytics tracking image in it.

      When I receive the DM it is empty.

      It looks like REST API removes all text from the message (not just the image, but all the content of the DM is being deleted) and sends empty message.

      I wonder if this is intended behavior or a bug?

       

      For reference, this is what I'm sending:

      <ol style="margin: 0px; padding: 0px; border: 0px; outline: 0px; font-size: 12px; font-family: Helvetica, Arial, sans-serif; vertical-align: baseline; list-style: none; color: #323537; line-height: 18px;">This is the Community Managers,</ol>

      <ol style="margin: 0px; padding: 0px; border: 0px; outline: 0px; font-size: 12px; font-family: Helvetica, Arial, sans-serif; vertical-align: baseline; list-style: none; color: #323537; line-height: 18px;">You need to do X, Y, and Z.</ol>

      <p> </p>

      <p><img src="http://www.google-analytics.com/collect?v=1&tid=UA-ZZZZZZZ-1&t=event&ec=email&ea=open&cs=caex&cm=email&cn=test1" /></p>

      <ol style="margin: 0px; padding: 0px; border: 0px; outline: 0px; font-size: 12px; font-family: Helvetica, Arial, sans-serif; vertical-align: baseline; list-style: none; color: #323537; line-height: 18px;">Thanks,</ol>

      <ol style="margin: 0px; padding: 0px; border: 0px; outline: 0px; font-size: 12px; font-family: Helvetica, Arial, sans-serif; vertical-align: baseline; list-style: none; color: #323537; line-height: 18px;">

      <ol style="margin: 0px; padding: 0px; border: 0px; outline: 0px; font-size: 12px; font-family: Helvetica, Arial, sans-serif; vertical-align: baseline; list-style: none; color: #323537; line-height: 18px;">Andrey</ol>

      </ol>

       

      And here is the fragment of the REST API response:

      {

        "type" : "dm",

        "subject" : "",

        "participants" : [ ],

        "parent" : "https://vaforumfor.us/api/core/v3/people/ZZZZ",

        "content" : {

          "type" : "text/html",

          "text" : "<body><!-- [DocumentBodyStart:ba5e9208-b3a1-45ed-a0e6-4bd9a2570cca] --><div class=\"jive-rendered-content\"></div><!-- [DocumentBodyEnd:ba5e9208-b3a1-45ed-a0e6-4bd9a2570cca] --></body>"

        },

      .......

       

      When I remove the img tag from the DM the whole message gets delivered just fine.

       

      I would appreciate the community help.

       

      Regards,

      Andrey Mikhalchuk