2 Replies Latest reply on Jan 14, 2015 6:10 AM by msoltow

    Problems When Changing DNS Records for App Server

    msoltow

      Last night, we attempted to switch the server that hosts three of our Jive Apps (as three separate add-ons) to a different AWS instance.  In order to maintain continuity, rather than changing the URL to our apps, we opted to attempt to change the DNS CNAME record to point from the old server from the new server.  Since, as a result of this change, the URL to the new server would be the same as the URL to the old server, we did not anticipate that we would need to make any changes to our add-on packages (all the service URLs and OAuth URLs should have remained the same).

       

      However, after deploying the new server and changing the DNS record, all of our apps stopped working.  Even though our app service URLs worked perfectly with the new server outside the App framework (including accessing the app.xml file directly from the browser), when we tried to load the apps from within the app framework in our Jive instance, we kept receiving the message "This App cannot be loaded at this time."

       

      Our hunch is that there might be a DNS caching problem with the app proxy server.  Does this sound plausible?  If so, how can we clear the cache so that the App framework can successfully access the new server?

       

      We tried uninstalling the relevant add-ons after making the DNS change, but we were unable to do so.  Every time we clicked "uninstall" for an add-on, we were met with a 500 internal server error.

       

      One idea that we didn't have time to try was to perform the following steps:

       

      1. Shut down the old server
      2. Uninstall all add-ons
      3. Switch the DNS record
      4. Start up the new server
      5. Re-install the add-ons with new UUIDs

       

      Would these steps work?  And even if they would, is there an easier way to get around this issue?

       

      Thank you very much in advance for your help!