4 Replies Latest reply on Feb 24, 2015 1:21 PM by david.bastedo

    Settings not saving in Admin Console?

    erinclements

      Hi,

      I'm not sure where this question belongs, so I thought I'd start here.  I am trying to turn on a macro in the Admin Console under Spaces>Settings>Filters and Macros (it is the Brightcove Custom Video Provider Macro).  I have gone in and edited the settings to include the required information, but when I try to switch it to "On" and save the settings, it defaults back to "Off".  Is there a reason that this is happening?  Is there anything I can do to fix it?  Thanks so much,

       

      Erin

        • Re: Settings not saving in Admin Console?

          Hi erinclements - Can you verify that you've filled out the playerKey and playerID fields when configuring the Brightcove macro?

           

          Screen Shot 2015-02-18 at 10.37.44 AM.png

           

          From our product docs:

          https://docs.jivesoftware.com/cloud_int/comm_mgr/jive.help.core/#admin/ConfiguringVideoProviderBrightcove.html

           

          Adding Brightcove as a Video Provider

           

          You can allow your users to embed videos hosted by Brightcove in their content by specifying the Player ID and Partner ID associated with your Brightcove repository in a custom macro.

          If you use Brightcove to host videos and want to make them available for users to post in your community, you'll need to specify the settings for your site using a macro which you can then enable and disable.
          1. Upload your videos using the Brightcove Media Management UI and make sure they're available for viewing.
          2. In the Brightcove media management UI, across from a video, copy the embed codes for the video
          3. Get the {PLAYER_ID} and {PLAYER_KEY} that identify your site.
          4. In the Admin Console under Spaces > Settings > Filters and Macros, edit the settings for the CustomVideoMacro: brightcove macro and use these values to populate the playerID and partnerID settings. Make sure you select the space where you want to enable this provider. If you want to apply the setting community-wide, select the root space.
          5. Make sure that macro is set to On. (Note that when you disable a provider macro that has been enabled previously, videos already embedded from that provider will show as disabled.) When your users embed videos from the Web in content, they'll see Brightcove as a video provider option below the embed code field, and will be able to paste video embed code from Brightcove into the field to successfully post and play videos.
            • Re: Settings not saving in Admin Console?
              erinclements

              Hi David,

              I was able to get it to turn on by re-entering my player key, I must have entered it wrong before.  However, whenever we embed a Brightcove video into a document, all we are getting is a big blank space where the video should be.  Jive will only allow me to use the JavaScript embed code, when I use a URL (like the youtube example when you embed a video) it will not let me continue.  Is there something else I should be doing?  Thank you so much for your help! 

            • Re: Settings not saving in Admin Console?

              As a heads up for anyone else running into this same issue on their own Jive instances, it was determined through a support case investigation that there are two bugs associated with the Brightcove macro not working when embedding videos: JIVE-49587 & JIVE-49588. 

               

              With these bugs it's been determined that Brightcove videos are not playing in Jive 7.0.2 and 7.0.3.  The issues are resolved at this point and will be included in the upcoming 7.0.4 release.  A schedule of when 7.0.4 will be released will be posted here: Jive Release Schedule