3 Replies Latest reply on May 8, 2015 3:21 PM by jeph.yang

    Invalid Literal Error while starting Jive Services

    jaskiran

      Hi all,

       

      We are trying to setup a jive 8 instance for Demo purpose. We are Using 2 VMs each with almost 3.5 GB. The installation of the RPM goes properly and the enabling commands also executes correctly. However when we try to start the services, the system hangs for a few second after start. Then the services stops working. Any request to stop the service or check status or un-install the RPM gives following error.

       

      We are enabling a few basic services only.

       

      Traceback (most recent call last):

        File "/usr/local/jive/python/bin/jive", line 9, in <module>

          load_entry_point('jive-cli==2.1.8', 'console_scripts', 'jive')()

        File "/usr/local/jive/python/lib/python2.7/site-packages/jive_cli/jive.py", line 96, in main

          args.func(args)

        File "/usr/local/jive/python/lib/python2.7/site-packages/platform_cli/cli.py", line 157, in status

          service.status(args.verbose)

        File "/usr/local/jive/python/lib/python2.7/site-packages/platform_cli/service.py", line 310, in status

          main_proc = self._get_running_process_if_exists()

        File "/usr/local/jive/python/lib/python2.7/site-packages/platform_cli/service.py", line 242, in _get_running_process_if_exists

          pid = int(pidfile.read().strip())

      ValueError: invalid literal for int() with base 10: ''.

       

      Due to this we are unable to un-install as well. Kindly help or suggest any solution or alternative.

       

      Thanks In Advance

      Jaskiran