3 Replies Latest reply on Aug 25, 2017 5:52 AM by poisson

    Webhook callback not working

    pankaj.rajankar

      Hello everyone,

       

      Facing an issue with webhooks, not getting a call back from Jive when the event is triggered (ie. when we get a reply to a discussion)

       

      These are the steps I followed

      1. added a add on through Admin Console (tried both options Visible to me and Visible to Everyone)

      2. got the auth token

      3. registered a webhook and got a success message back

      {

        "id" : "1001",

        "resources" : {

          "self" : {

            "allowed" : [ "DELETE", "PUT", "GET" ],

            "ref" : "https://test.community.com/api/core/v3/webhooks/1001"

          }

        },

        "object" : "https://test.community.com/api/core/v3/places/1082",

        "events" : "document,post,discussion",

        "callback" : "https://test.myserver.com/JiveForumListner.action"

      }

      4. Went to Admin Console and tested the callback URL from 'Proxy Server' screen and our community is able to call the call back URL.

      5. Tested the service by POSTing a dummy message through browser and the call back service works.

       

      Can you please check if any of my steps are incorrect and suggest what more I can try.

       

      Thanks,

      Pankaj

        • Re: Webhook callback not working

          Can you confirm which version of Jive you are using?  sunny k recently posted a similar scenario and I am looking into it for him.  Just wanted to see if you were using Jive 7.0.0.1 or not?  Also, is your instance air-gapped?  Just curious for any environmental details you could share.

          • Re: Webhook callback not working
            wipkands

            Hi Pankaj,

             

            Is the issue all set now? As Ryan mentioned I am also facing same issue.

             

            Suneel

            • Re: Webhook callback not working
              poisson

              I'm also facing the same issue.

               

              The webhook service returns success when I create the webhook but when I generate an event (create a document in the place I'm listening to), nothing gets generated.

               

              I did notice a log event in the sbs.log that seems to occur only when a webhooked document is modified:

               

              com.jivesoftware.base.event.v2.nonBlockEventDispatchImple: Event [ DocumentEvent{...}] has a parameter that is not Serializable.

               

              I tried following the code but it seems that nothing triggers an entry in the WebhookQueueFeeder (and thus the WebhookQueueConsumer never even tries to callback).

               

              We're on Jive 7.0.3.1 , air-gapped.