2 Replies Latest reply on Dec 15, 2015 2:37 AM by mcollinge

    Default comments.soy will not save in custom theme

    Richard Fears

      Some background: I'm currently working through an odd i18n issue (wrong text displayed in various spots). I've discovered that adding the default code for the relevant soy file to our custom theme will force the renderer to re-evaluate and thus display the correct text. This has worked fine for every soy file I've tried it on with one exception: /soy/comment_app/comments.soy

       

      I add comments.soy to the custom theme and click save, but it throws this error:

      Error compiling template: In file /home/jive/applications/sbs/home/temp/SoyTemplateSyntaxTester7927909819951814521975970387:16, template jive.CommentApp.soy.renderReply: Found unbound global '_jive_current_user.anonymous'.

       

      I've attached a copy of the default comments.soy file for reference. We are on SBS 8.0.1 with a custom WAR. Note that the offending portion in the file is related to the user's avatar that displays when adding a comment. Removing that will remove the avatar but will allow me to save the file (fixing the i18n issue).

       

      Is anyone else experiencing this issue? Any suggestions for fixing it?

       

      Thanks,

      Richard

        • Re: Default comments.soy will not save in custom theme
          mcollinge

          We saw something similar with i18ns.. you could try bumping the resource salt, which should get the system to re-evaluate all the soy & JavaScript.. that'll be better than having to overlay all the Soy files.

           

          e.g.

           

          jive.resource.salt = 2015-12-15

           

          I think there were changes/fixes in 8.0.2.0 to do with resource loading and i18ns.

           

          We also ended up setting these sys props to solve other i18n and Soy problems.

           

          jive.resources.split.sub.soy.templates  =  false   (this one solved issues we had overlaying certain core Soy files)

          jive.enabled.resources.externalize.min.i18n  =  false   (this one solved issues we had referencing i18ns via JavaScript)

          __jive.minify.soy.i18n.keys = false