3 Replies Latest reply on Jun 24, 2016 9:18 AM by jesse.fuller

    Text doesn't flow around tables.

    brianswilson

      Issue

      This issue has been a real problem and I haven't been able to find any solution.  Everything I've tried has failed, but this message seems to have got things working properly.  There seems to be an invisible paragraph to the left of the table in this message, but not in my document.  This is easier to see in the HTML portion of the editor.

       

      Header 1Header 2Header 3
      blahblahblah
      blahblahblay

      Explaination

      I've got a table and I would like the document text to flow around the table on the left.  I selected the "Align Right" icon for the table, but the text does not flow around the table as expected (or indicated on the icon).  How can I get this working?  It does not matter if the text precedes the table, or follows the table.  Nothing I've tried seems to be able to get the text to flow around the table.  For some reason it is working in this message, but I have no idea why it won't work in my document.

       

      Conlusion

      In edit mode, the text and table appear side-by-side as you would expect, but once you save the document and quit editing, the text appears after the table instead of next to the table.  If I look at this message in the HTML format, the text that is wrapped on the left follows the table.  In my document, I have an <h2> heading rather than a paragraph, but that shouldn't cause this issue.  I'll add some here to see if that changes anything. Nope it doesn't.

       

      Even if I cut and paste the contents of this message as HTML, it still doesn't display correctly in my document.  If I cut and paste the HTML text from the Jive editor into an HTML file, the formatting is correct and the float works as expected.  Clearly Jive has a bug with respect to this feature.  While I was able to set the style so the "margin: 0 0 8px 8px;" and this seems to work (i.e. words no longer but up against the table lines in this message), I noticed that entering the html tag '<br clear="all" />' keeps being removed when I "update" the edited work.  This means there's no way to stop the alignment/text wrapping.  This would also seem to be a rather major issue with this tool.

        • Re: Text doesn't flow around tables.

          Hi Brian,

           

          Reviewing through your description, as you mention the behavior is not appearing here in this discussion, however you see it in documents, it's possible you are running into a bug being tracked as JIVE-69431 (which impacts blogs and documents). However, to confirm, I would recommend submitting a case in your secret customer group here in the Jive Community where the next available support member can review through your instance to confirm the behavior and associate the bug with your community for tracking, if applicable.

           

          Thanks!

            • Re: Text doesn't flow around tables.
              brianswilson

              Wow, there's a "secret consumer group"?  Do we get decoder rings, or is this more like double secret probation?

               

              I've searched and apparently "secret" is the operative word since I can't find any reference to a JIVE-69431 ticket, or any "secret consumer group".  At this point, I've got better things to do with my time that chase this apparently known bug down whatever rabbit hole has been devised.

               

              If you ever get a solution to your bug, let me know.  In the mean time, I'll be looking for better tools that aren't quite so "secret" in providing customer assistance.