5 Replies Latest reply on Oct 5, 2016 5:31 AM by kristengastaldo

    Unable to embed a video in a system blog

    Alex Nassi

      I came across an issue that was also reported at Where did the shortcut to embed video into a system blog go? , but the discussion is locked and I cannot add that comment.

       

      I recently created a system blog for multiple employees to use, but ran into an issue where an embedded (YouTube) video was not working. Like the above discussion, the "Embed Video" button is not available in the toolbar when creating a blog post from the system blog menu:

      Screen Shot 2016-07-27 at 8.59.36 PM.png

      However, when I go to a group or space and try to create a blog, the button is available:

      Screen Shot 2016-07-27 at 9.01.17 PM.png

       

      To try and work around this issue, I tried copying the HTML from the other space to the system blog. This works when I view it (a system admin), but when a regular user tried to watch the video, he received the following Unauthorized error on the video frame:

      Screen Shot 2016-07-27 at 4.34.32 PM.png

       

      As another workaround, I tried creating the blog post in the other space (to get the correct menu bar) and embedding the video after changing the destination of the blog to the system blog. After going through the embed process on the popup window, I recieved an Unexpected Error:

      Screen Shot 2016-07-27 at 9.05.32 PM.png

       

      This seems like a possible bug to me as I don't see any reason why you cannot embed a video on a system blog, but can everywhere else.

       

      I'm curious if there were any details or reason found in the case that sarah.klenakis filed per Jesse Fuller's suggestion? Or if anyone else has run into this issue before and has another workaround to try?