1 Reply Latest reply on Apr 24, 2017 9:28 AM by mbrybag

    Export Jive content DB to local Jive 7 instance

    mbrybag

      Hello All!

       

      I have a vanilla instance of Jive 7.0.3 running on my local Windows 10 machine(Same Jive version as our PROD and test instances).

      I tried downloading our Jive PROD DB from Jive Cloud admin and importing that postgres db to use for my local instance. I had this working on my last laptop but since I have a new one Ive been unable to get my local jive instance to work with our PROD database. So i can only run my local site without content.

       

      The error I get is that on selecting the -eae database on the intiial JIVE site setup, I get a pop up box that just says "Error"

       

      This -eae db is blank. if i run the setup with a blank content DB then it lets me use this -eae database with no issues. But the minute I switch out the content DB for the PROD or even Test Jive content DB that has content, I get an error at this step.

       

      If i enter the wrong credentials then I get a concrete error message saying pwd authentication failed for this user. So Ive ruled out incorrect credentials.

       

      I do see this in the sbs.log when the error pop up shows up:

       

      2017-03-01 14:55:17,228 [http-bio-8080-exec-10] [::] WARN org.directwebremoting.dwrp.BaseCallMarshaller - --Erroring: batchId[4] message[java.lang.NullPointerException]

      2017-03-01 15:02:05,103 [http-bio-8080-exec-3] [::] WARN org.directwebremoting.impl.DefaultRemoter - Method execution failed:

      java.lang.NullPointerException

        at com.jivesoftware.community.action.admin.AdminDatabaseUtilAction.testActivityEngineConnection(AdminDatabaseUtilAction.java:58)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      .....

        at java.lang.Thread.run(Thread.java:745)

      2017-03-01 15:02:05,107 [http-bio-8080-exec-3] [::] WARN org.directwebremoting.dwrp.BaseCallMarshaller - --Erroring: batchId[6] message[java.lang.NullPointerException]

       

       

      Any ideas where I can look for more information?