0 Replies Latest reply on Dec 23, 2017 10:25 AM by karol.walasek

    Issues with OAuth2, Access Denied. How do I get this to work?

    karol.walasek

      I was trying to get the example-webhooks to work (Getting Started > Using Webhooks with the Jive Node SDK ). Unfortunately I've had many issues with this:

      1. About a month ago - it worked fine
      2. Two weeks ago after redirecting to oauth2/authorize the Jive Sandbox server responds with Error 1 (posted later)
      3. Today I discovered Error 1 shows up when a valid redirect_uri is given (if an invalid uri is given then a proper error message appears with invalid_redirect_uri)
      4. If redirect_uri is ommited then an interface is shown properly with the "Allow" button, but after clicking it Error 2 appears

       

      The Error 1 looks like this:

       

      Access Denied
      You don't have permission to access "http://sandbox.jiveon.com/oauth2/authorize/?" on this server.
      Reference #18.9c3c5168.1514037466.fb47a95

       

      Error 2:

       

      Access Denied
      You don't have permission to access "http://sandbox.jiveon.com/oauth2-authorize!execute.jspa" on this server.
      Reference #18.9c3c5168.1514037703.fb82494

       

      I'm really confused about this. I've already tried doing Reconnect to service from the add-ons screen.

      The errors show "http", but "https" is being used (although the redirect_uri contained http).

      Any ideas what steps should I do to try and debug this?