0 Replies Latest reply on May 23, 2018 2:11 AM by diamchik

    Slow playback in Add-on (apps) for youtube embedded video

    diamchik

      Hi all,

       

      We've builded add-on like a small web-application (backend is on remote server and backend stores html-layouts for add-on views).

      Add-on uses views as iframe from server (app.xml), e.g.:

      <Content type="html"
         view="home"
         href="https://server.com/somepage"
         authz="signed"
         sign_viewer="true"/>

       

      On the views (html) we use embedded video from youtube (link is like "https://www.youtube.com/embed/nEVn55GniUQ?enablejsapi=1&wmode=opaque").


      Problem: video has slow motion playback and entire page looks slowly and jerky.

      Also any animation with js has the same issue with slow rendering on the page.

      Should we show video with another way?
      What can be issue for that?
      Any ideas/thoughts, guys?

      We've included some features in app.xml file, maybe are these libraries make such slowly state of page when there is some action on the page (because we have other scripts on server side)?

      <Require feature="dynamic-height"/>
      <Require feature="jquery-1.11"/>
      <Require feature="osapi"/>
      <Require feature="settitle"/>
      <Require feature="views"/>
      <Require feature="jive-core-v3"/>
      <Require feature="jive-core-v3-resolver"/>
      <Require feature="embedded-experiences"/>
      <Require feature="jive-custom-settings-1.0.0"/>
      <Require feature="jive-opensocial-ext-v1"/>
      <Require feature="opensocial-data"/>
      <Require feature="setprefs"/>
      <Require feature="selection"/>
      <Require feature="embedded-experiences"/>
      <Require feature="actions">

       

      We use Linux, Ubuntu 16.04; Chrome, version 66.0.3359.181 (Official Build) (64-bit).

       

      Thanks in advance.