3 Replies Latest reply on Jul 24, 2018 11:04 PM by jgoldhammer

    Problem with installing jive-hosted app on Jive 2018.2.4.0

    michael_yegorov

      Hello!

      Recently I ran into a strange behavior. I tried to install an addon on jive 2018.2.4.0 with jive apps market enabled and at first it failed to install it, then it's been installed but other people don't see it. When they enter /apps/estimate-reports they just see apps market.

      Here's my jiveclientconfiguration.json:

      {
          "clientUrl": "http://localhost",
          "port": "8090",
          "development": true,
          "clientUrlExcludesPort": true,
          "logLevel": "DEBUG",
          "logFile" : "logs/jive-sdk.log",
          "logFileSize" : 20480,
          "extensionInfo": {
              "id": "8fcbc33f-2b67-499c-9238-12ba1a1283e8",
              "uuid": "8fcbc33f-2b67-499c-9238-12ba1a1283e8",
              "name": "Estimate reports",
              "description": "-",
              "icon_16": "extension-16.png",
              "icon_48": "extension-48.png",
              "icon_128": "extension-128.png",
              "releasedOn": "2018-07-12T10:55:34.240Z",
              "ignoreExtensionRegistrationSource": true,
              "suppressAddonRegistration": true
          },
          "forPropertyDocumentation": "https://community.jivesoftware.com/docs/DOC-103487"
      }

       

      I have one app there with a simple definition.json:

      {
         "id" : "4c6617b4-3300-4134-a280-13f7aff16894",
         "name" : "Estimate reports",
         "appPath": "estimate-reports"
      }

       

      This app runs successfully on local 9.0.3 instance and on cloud 2016.3.10.0

       

      Any thoughts?