0 Replies Latest reply on May 7, 2010 2:27 PM by John_C

    What is going on with Pidgin and the "Not Authorized" problem

      A number of tickets have been opened and closed with no real resolution for this problem.  Now, these users might be facing something more seerious than I was, but their problems sounded a lot like mine, but I found out how to fix it.  Here are the URL's of some pages talking about what may or may not be the same problem:

       

      http://developer.pidgin.im/ticket/5008

      http://developer.pidgin.im/ticket/5149

      http://developer.pidgin.im/ticket/5161

      http://www.igniterealtime.org/community/message/166228#166228

      http://blog.elsdoerfer.name/2008/04/28/openfire-md5-digest-psi-pidgin/

       

      They concluded that you must add xmpp.fqdn to the server setup in order to get Pidgin to talk to OpenFire correctly.  I have not yet found this to be the case.  Now, I am behind a router, and had at first tested it as localhost, and then as 192.168.0.xxx, and everything seemed to go fine.  I could create multiple accounts through Pidgin, and have them show up in OpenFilre just fine.  I could add them as buddies, and chat back and forth between buddies, with two or more chat windows open in the same Pidgin instance at the same time.  I suppose a subtle bug is involved, but nothing very important.  I then created a fresh install, and tried the same thing on the WAN, using my external IP numbers as an address.  Suddenly, I started getting these "Not Authorized" messages on my buddy list.  I tried the solutions posted on those pages, and got no solution.  Other IM's could log into those accounst just fine, however.  After many frusterating hours, and even deleting and giving up on Pidgin, I installed it again, after finding out the difficulty and limitations of creating custom SSL keys in other applications.  After much playing around, I figured out a procedure that could get those accounts installed in good standing in Pidgin.  I forget exactly how I figured it out, but getting the accounts to function correctly always had to do with accepting them as buddies.  Then it finally dawned on me.  It wasn't telling me that those accounts were failing the account authentication on the server.  It was merely telling me that the person I was choosing as a Buddy had not yet okayed me to be on his buddy list!  I deleted all my accounts, and began to use it like a normal IM.  I had no trouble creating one pre-existing account, searching for users, adding one as a buddy, going into another IM, accepting my other account as a buddy, and chatting back and forth.  What seems to be happening, is that when you go from a LAN server to a WAN server, Pidgin and/or OpenFire get confused, and begins behaving differently; but only when you have accunts on Pidgin that are also buddies.  This normally never happens, but is a natural thing to try when settng up OpenFire for Pidgin.  It seems that when you have an account that is also a buddy in Pidgin, for some unknown reason, you never get prompted if you want yourself to be on your own buddy list -but only if you are on a WAN, not a LAN, sever.  So the moral of the story is, just avoid having accounts also as buddies on Pidgin at the same time when using OpenFire, and your problems very well may disappear, as mine did.

       

      Cheers!

      John_C